# CVE-2019-6339: PHAR stream wrapper Arbitrary PHP code execution

> Remote attackers can execute arbitrary PHP code via untrusted phar URIs in Drupal, requiring administrative permissions or atypical configurations.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2019
- **Updated:** 16 Sep 2024
- **Also known as:** DLA-1659-1, DRUPAL-CORE-2019-002, GHSA-8cw5-rv98-5c46, UBUNTU-CVE-2019-6339

## What is CVE-2019-6339?

CVE-2019-6339 is a critical code injection vulnerability in Debian Debian Linux, published on 22 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; A remote code execution vulnerability exists in PHP's built-in phar stream wrapper when performing file operations on an untrusted phar:// URI. Some Drupal code (core, contrib, and custom) may be performing file operations on insufficiently validated user input, thereby being exposed to this vulnerability. This vulnerability is mitigated by the fact that such code paths typically require access to an administrative permission or an atypical configuration.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2019-6339?

13 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 7.0.0 | 7.62.0 |
| `drupal/core` | Packagist | From 7.0.0 | 7.62.0 |
| `drupal/core` | Packagist | From 8.0.0 | 8.5.9, 8.6.6 |
| `drupal/core` | Packagist | From 8.0.0 | 8.5.9 |
| `drupal/core` | Packagist | From 8.0.0 | 8.5.9 |
| `drupal/core` | Packagist | From 8.6.0 | 8.6.6 |
| `drupal/core` | Packagist | From 8.6.0 | 8.6.6 |
| `drupal/drupal` | Packagist | From 7.0.0 | 7.62.0 |
| `drupal/drupal` | Packagist | From 7.0.0 | 7.62.0 |
| `drupal/drupal` | Packagist | From 8.0.0 | 8.5.9 |
| `drupal/drupal` | Packagist | From 8.0.0 | 8.5.9 |
| `drupal/drupal` | Packagist | From 8.6.0 | 8.6.6 |
| `drupal/drupal` | Packagist | From 8.6.0 | 8.6.6 |

Products: Debian Debian Linux, Drupal Drupal.

## How do I fix CVE-2019-6339?

Upgrade drupal/core to a fixed version for your release line: 7.62.0, 8.5.9 or 8.6.6.

## Is CVE-2019-6339 being exploited?

There is no known exploitation of CVE-2019-6339 in the wild and no public exploit code.

Public exploit code:

- Drupal remote code execution vulnerabilty (github_poc): https://github.com/Vulnmachines/drupal-cve-2019-6339

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-6339 and fix it if it is affected.

What it is: CVE-2019-6339 is a critical code injection vulnerability in Debian Debian Linux, published on 22 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-6339 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 7.0.0; fixed in 7.62.0
- drupal/core (Packagist): affected from 7.0.0; fixed in 7.62.0
- drupal/core (Packagist): affected from 8.0.0; fixed in 8.5.9, 8.6.6
- drupal/core (Packagist): affected from 8.0.0; fixed in 8.5.9
- drupal/core (Packagist): affected from 8.0.0; fixed in 8.5.9
- drupal/core (Packagist): affected from 8.6.0; fixed in 8.6.6
- drupal/core (Packagist): affected from 8.6.0; fixed in 8.6.6
- drupal/drupal (Packagist): affected from 7.0.0; fixed in 7.62.0
- drupal/drupal (Packagist): affected from 7.0.0; fixed in 7.62.0
- drupal/drupal (Packagist): affected from 8.0.0; fixed in 8.5.9
- drupal/drupal (Packagist): affected from 8.0.0; fixed in 8.5.9
- drupal/drupal (Packagist): affected from 8.6.0; fixed in 8.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-6339/ (Markdown: https://insights.sbomify.com/CVE-2019-6339/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-6339
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-6339
- OSV: https://osv.dev/vulnerability/CVE-2019-6339

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-6339/
Summaries are generated and may contain mistakes; the official description above is the record.
