CVE-2019-6341 Drupal core - Moderately critical - Cross Site Scripting - SA-CORE-2019-004
A malicious user can upload a file to trigger cross-site scripting, potentially leading to code execution or account takeover in Drupal.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-6341?
CVE-2019-6341 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 26 Mar 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
In Drupal 7 versions prior to 7.65; Drupal 8.6 versions prior to 8.6.13;Drupal 8.5 versions prior to 8.5.14. Under certain circumstances the File module/subsystem allows a malicious user to upload a file that can trigger a cross-site scripting (XSS) vulnerability.
Weakness: CWE-79
Which versions are affected by CVE-2019-6341?
13 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 7.0.0 | 7.65.0 |
drupal/core Packagist | From 7.0.0 | 7.65.0 |
drupal/core Packagist | From 8.0.0 | 8.5.14, 8.6.13 |
drupal/core Packagist | From 8.0.0 | 8.5.14 |
drupal/core Packagist | From 8.0.0 | 8.5.14 |
drupal/core Packagist | From 8.6.0 | 8.6.13 |
7 more packages
drupal/core Packagist | From 8.6.0 | 8.6.13 |
drupal/drupal Packagist | From 7.0.0 | 7.65.0 |
drupal/drupal Packagist | From 7.0.0 | 7.65.0 |
drupal/drupal Packagist | From 8.0.0 | 8.5.14 |
drupal/drupal Packagist | From 8.0.0 | 8.5.14 |
drupal/drupal Packagist | From 8.6.0 | 8.6.13 |
drupal/drupal Packagist | From 8.6.0 | 8.6.13 |
Products include Debian Debian Linux, Drupal Drupal, Fedoraproject Fedora.
How do I fix CVE-2019-6341?
Upgrade drupal/core to a fixed version for your release line: 7.65.0, 8.5.14 or 8.6.13.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-6341 being exploited?
There is no known exploitation of CVE-2019-6341 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2024-WW17035, DLA-1746-1, DRUPAL-CORE-2019-004, DSA-4412-1, GHSA-cmmh-8mwp-gq5p, UBUNTU-CVE-2019-6341.