# CVE-2019-6342: Drupal core - Critical - Access bypass - SA-CORE-2019-008

> Attackers can bypass access controls when the experimental Workspaces module is enabled in Drupal 8 core.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DRUPAL-CORE-2019-008, GHSA-xq62-62c9-22mg, UBUNTU-CVE-2019-6342

## What is CVE-2019-6342?

CVE-2019-6342 is a critical authentication bypass vulnerability in Drupal Drupal, published on 28 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An access bypass vulnerability exists when the experimental Workspaces module in Drupal 8 core is enabled. This can be mitigated by disabling the Workspaces module. It does not affect any release other than Drupal 8.7.4.

## Which versions are affected by CVE-2019-6342?

2 open source packages ship an affected version, including drupal/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 8.7.4 | 8.7.5 |
| `drupal/core` | Packagist | From 8.7.4 | 8.7.5 |

Products: Drupal Drupal.

## How do I fix CVE-2019-6342?

Upgrade drupal/core to 8.7.5 or later.

## Is CVE-2019-6342 being exploited?

There is no known exploitation of CVE-2019-6342 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-6342 and fix it if it is affected.

What it is: CVE-2019-6342 is a critical authentication bypass vulnerability in Drupal Drupal, published on 28 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-6342 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 8.7.4; fixed in 8.7.5
- drupal/core (Packagist): affected from 8.7.4; fixed in 8.7.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-6342/ (Markdown: https://insights.sbomify.com/CVE-2019-6342/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-6342
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-6342
- OSV: https://osv.dev/vulnerability/CVE-2019-6342

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-6342/
Summaries are generated and may contain mistakes; the official description above is the record.
