{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-6438 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2019-6438 is a critical vulnerability in Opensuse Leap, published on 31 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-6438 and fix it if it is affected.\n\nWhat it is: CVE-2019-6438 is a critical vulnerability in Opensuse Leap, published on 31 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-6438 in the wild and no public exploit code.\n\nAffected product: Opensuse Leap. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-6438/ (Markdown: https://insights.sbomify.com/CVE-2019-6438/index.md)","id":"CVE-2019-6438","markdown":"https://insights.sbomify.com/CVE-2019-6438/index.md","name":"CVE-2019-6438","record":{"aliases":["GHSA-29g2-g2r5-p4x5","SUSE-SU-2019:0960-1","SUSE-SU-2019:3385-1","UBUNTU-CVE-2019-6438","openSUSE-SU-2019:1264-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Slurm workload manager","requires_auth":"none","summary":"Slurm workload manager mishandles 32-bit systems, potentially causing service disruption or instability on affected architectures.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"leap","vendor":"opensuse"},{"product":"slurm","vendor":"schedmd"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"SchedMD Slurm before 17.11.13 and 18.x before 18.08.5 mishandles 32-bit systems.","ecosystems":["SUSE:Linux Enterprise Module for HPC 12","SUSE:Linux Enterprise Module for HPC 15","openSUSE:Leap 15.0"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Other in n/a","id":"CVE-2019-6438","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"opensuse:leap","products":["opensuse:leap"],"type":"other","year":"2019"},"n_packages":3,"n_references":4,"next":{"headline":"Memory corruption in n/a","id":"CVE-2019-6439"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for HPC 12","fixed":["17.02.11-6.36.1"],"introduced":["0"],"last_affected":[],"package":"slurm","purl":"pkg:rpm/suse/slurm\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20HPC%2012","source":"SUSE-SU-2019:3385-1"},{"ecosystem":"SUSE:Linux Enterprise Module for HPC 15","fixed":["17.11.13-6.15.17"],"introduced":["0"],"last_affected":[],"package":"slurm","purl":"pkg:rpm/suse/slurm\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20HPC%2015","source":"SUSE-SU-2019:0960-1"},{"ecosystem":"openSUSE:Leap 15.0","fixed":["17.11.13-lp150.5.20.1"],"introduced":["0"],"last_affected":[],"package":"slurm","purl":"pkg:rpm/opensuse/slurm\u0026distro=openSUSE%20Leap%2015.0","source":"openSUSE-SU-2019:1264-1"}],"prev":{"headline":"Drupal core - Critical - Access bypass - SA-CORE-2019-008","id":"CVE-2019-6342"},"products":["n/a"],"published":"2019-01-31","related":[{"cvss_score":5.3,"headline":"Oracle Java SE Integrity Check","id":"CVE-2015-4902","kev_date_added":"2022-03-03","published":"2015-10-21"},{"cvss_score":9.9,"headline":"package builds could use directory traversal to write outside of target area","id":"CVE-2017-14804","kev_date_added":null,"published":"2018-03-01"},{"cvss_score":9.8,"headline":"Teeworlds before 0.7.4 has an integer overflow when computing a tilemap size.","id":"CVE-2019-20787","kev_date_added":null,"published":"2020-04-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2019-8341","kev_date_added":null,"published":"2019-02-15"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-18215","kev_date_added":null,"published":"2018-03-05"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-6542","kev_date_added":null,"published":"2017-03-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Slurm workload manager mishandles 32-bit systems, potentially causing service disruption or instability on affected architectures.","url":"https://insights.sbomify.com/CVE-2019-6438/"}