# CVE-2019-6486: Denial of service in n/a

> Attackers can cause CPU exhaustion or recover private keys via mishandled elliptic curves in the Go standard library.

- **Severity:** High 8.2 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jan 2019
- **Updated:** 4 Aug 2024
- **Also known as:** AZL-79018, AZL-98958, DLA-1664-1, GHSA-vj2x-6gjj-jvh2, GO-2022-0217, SUSE-SU-2019:0651-1, SUSE-SU-2019:1149-1, UBUNTU-CVE-2019-6486, openSUSE-SU-2019:1164-1

## What is CVE-2019-6486?

CVE-2019-6486 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 24 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Go before 1.10.8 and 1.11.x before 1.11.5 mishandles P-521 and P-384 elliptic curves, which allows attackers to cause a denial of service (CPU consumption) or possibly conduct ECDH private key recovery attacks.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2019-6486?

1 open source package ship an affected version, including stdlib. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `stdlib` | Go | All versions | 1.10.8, 1.11.5 |
| `go1.11` | openSUSE:Leap 15.0 | All versions | 1.11.5-lp150.6.4 |

Products: Debian Debian Linux, Golang Go, Opensuse Leap.

## How do I fix CVE-2019-6486?

Upgrade stdlib to a fixed version for your release line: 1.10.8 or 1.11.5.

## Is CVE-2019-6486 being exploited?

There is no known exploitation of CVE-2019-6486 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-6486 and fix it if it is affected.

What it is: CVE-2019-6486 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 24 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-6486 in the wild and no public exploit code.

Affected packages and fixed versions:
- stdlib (Go): affected all versions; fixed in 1.10.8, 1.11.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-6486/ (Markdown: https://insights.sbomify.com/CVE-2019-6486/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-6486
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-6486
- OSV: https://osv.dev/vulnerability/CVE-2019-6486

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-6486/
Summaries are generated and may contain mistakes; the official description above is the record.
