{"answers":{"affected":"5 open source packages ship an affected version, including python-gnupg. It affects 5 products.","exploited":"There is no known exploitation of CVE-2019-6690 in the wild and no public exploit code.","fix":"Upgrade python-gnupg to 0.4.4 or later.","what":"CVE-2019-6690 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 17 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-6690 and fix it if it is affected.\n\nWhat it is: CVE-2019-6690 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 17 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-6690 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- python-gnupg (PyPI): affected all versions; fixed in 0.4.4\n- python-gnupg (PyPI): affected all versions; fixed in 0.4.4\n- python-gnupg (PyPI): affected all versions; fixed in 0.4.4\n- python-gnupg (PyPI): affected all versions; fixed in 0.4.4\n- python-gnupg (PyPI): affected all versions; fixed in 0.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-6690/ (Markdown: https://insights.sbomify.com/CVE-2019-6690/index.md)","id":"CVE-2019-6690","markdown":"https://insights.sbomify.com/CVE-2019-6690/index.md","name":"CVE-2019-6690","record":{"aliases":["DEBIAN-CVE-2019-6690","DLA-1675-1","GHSA-2fch-jvg5-crf6","GHSA-qh62-ch95-63wh","MGASA-2019-0105","PYSEC-2019-115","UBUNTU-CVE-2019-6690","openSUSE-SU-2019:0143-1","openSUSE-SU-2019:0239-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python GnuPG library","requires_auth":"none","summary":"Attackers can trick the library into decrypting unintended ciphertext if they control the passphrase, leading to unauthorized data access.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"leap","vendor":"opensuse"},{"product":"python-gnupg","vendor":"python"},{"product":"backports","vendor":"suse"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"python-gnupg 0.4.3 allows context-dependent attackers to trick gnupg to decrypt other ciphertext than intended. To perform the attack, the passphrase to gnupg must be controlled by the adversary and the ciphertext should be trusted. Related to a \"CWE-20: Improper Input Validation\" issue affecting the affect functionality component.","ecosystems":["PyPI","SUSE:Package Hub 15"],"exploits":{"exploitdb":0,"first_seen":"2019-01-20","github_poc":2,"max_poc_stars":6,"metasploit":0,"nuclei":0,"refs":[{"date":"2019-04-03T06:34:48Z","kind":"github_poc","ref":"https://github.com/brianwrf/CVE-2019-6690","stars":6,"title":"It is a simple PoC of Improper Input Validation in python-gnupg 0.4.3 (CVE-2019-6690)."},{"date":"2019-01-20T15:29:46Z","kind":"github_poc","ref":"https://github.com/stigtsp/CVE-2019-6690-python-gnupg-vulnerability","stars":1,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Improper Input Validation python-gnupg","id":"CVE-2019-6690","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","opensuse:leap"],"type":"other","year":"2019"},"n_packages":6,"n_references":13,"next":{"headline":"SQL injection in n/a","id":"CVE-2019-6691"},"packages":[{"ecosystem":"PyPI","fixed":["0.4.4"],"introduced":["0"],"last_affected":[],"package":"python-gnupg","purl":null,"source":"GHSA-2fch-jvg5-crf6"},{"ecosystem":"PyPI","fixed":["0.4.4"],"introduced":["0"],"last_affected":[],"package":"python-gnupg","purl":"pkg:pypi/python-gnupg","source":"GHSA-2fch-jvg5-crf6"},{"ecosystem":"PyPI","fixed":["0.4.4"],"introduced":["0"],"last_affected":[],"package":"python-gnupg","purl":null,"source":"GHSA-qh62-ch95-63wh"},{"ecosystem":"PyPI","fixed":["0.4.4"],"introduced":["0"],"last_affected":[],"package":"python-gnupg","purl":"pkg:pypi/python-gnupg","source":"GHSA-qh62-ch95-63wh"},{"ecosystem":"PyPI","fixed":["0.4.4"],"introduced":["0"],"last_affected":[],"package":"python-gnupg","purl":"pkg:pypi/python-gnupg","source":"PYSEC-2019-115"},{"ecosystem":"SUSE:Package Hub 15","fixed":["0.4.4-bp150.2.3.1"],"introduced":["0"],"last_affected":[],"package":"python-python-gnupg","purl":"pkg:rpm/suse/python-python-gnupg\u0026distro=SUSE%20Package%20Hub%2015","source":"openSUSE-SU-2019:0239-1"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2019-6689"},"products":["n/a"],"published":"2019-03-17","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can trick the library into decrypting unintended ciphertext if they control the passphrase, leading to unauthorized data access.","url":"https://insights.sbomify.com/CVE-2019-6690/"}