{"answers":{"affected":"2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-6799 exists.","fix":"Upgrade phpmyadmin/phpmyadmin to 4.8.5 or later.","what":"CVE-2019-6799 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 26 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-6799 and fix it if it is affected.\n\nWhat it is: CVE-2019-6799 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 26 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-6799 exists.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.8; fixed in 4.8.5\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.8; fixed in 4.8.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-6799/ (Markdown: https://insights.sbomify.com/CVE-2019-6799/index.md)","id":"CVE-2019-6799","markdown":"https://insights.sbomify.com/CVE-2019-6799/index.md","name":"CVE-2019-6799","record":{"aliases":["DEBIAN-CVE-2019-6799","DLA-1692-1","GHSA-c8wj-q36q-3wg4","UBUNTU-CVE-2019-6799"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"phpMyAdmin","requires_auth":"none","summary":"An attacker can read arbitrary files on the server via a rogue MySQL server when AllowArbitraryServer is enabled in phpMyAdmin.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[],"description":"An issue was discovered in phpMyAdmin before 4.8.5. When the AllowArbitraryServer configuration setting is set to true, with the use of a rogue MySQL server, an attacker can read any file on the server that the web server's user can access. This is related to the mysql.allow_local_infile PHP configuration, and the inadvertent ignoring of \"options(MYSQLI_OPT_LOCAL_INFILE\" calls.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2019/CVE-2019-6799.yaml","stars":null,"title":"phpMyAdmin \u003c4.8.5 - Local File Inclusion"}],"tier":"weaponised"},"has_fix":true,"headline":"phpMyAdmin Arbitrary file read vulnerability","id":"CVE-2019-6799","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"debian:debian_linux","products":["debian:debian_linux","phpmyadmin:phpmyadmin"],"type":"path_traversal","year":"2019"},"n_packages":2,"n_references":3,"next":{"headline":"Command injection in n/a","id":"CVE-2019-6800"},"packages":[{"ecosystem":"Packagist","fixed":["4.8.5"],"introduced":["4.8"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-c8wj-q36q-3wg4"},{"ecosystem":"Packagist","fixed":["4.8.5"],"introduced":["4.8"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-c8wj-q36q-3wg4"}],"prev":{"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-6798"},"products":["n/a"],"published":"2019-01-26","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"An attacker can read arbitrary files on the server via a rogue MySQL server when AllowArbitraryServer is enabled in phpMyAdmin.","url":"https://insights.sbomify.com/CVE-2019-6799/"}