{"answers":{"affected":"3 open source packages ship an affected version, including pypiserver. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-6802 exists.","fix":"Upgrade pypiserver to 1.2.6 or later.","what":"CVE-2019-6802 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-6802 and fix it if it is affected.\n\nWhat it is: CVE-2019-6802 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-6802 exists.\n\nAffected packages and fixed versions:\n- pypiserver (PyPI): affected all versions; fixed in 1.2.6\n- pypiserver (PyPI): affected all versions; fixed in 1.2.6\n- pypiserver (PyPI): affected all versions; fixed in 1.2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-6802/ (Markdown: https://insights.sbomify.com/CVE-2019-6802/index.md)","id":"CVE-2019-6802","markdown":"https://insights.sbomify.com/CVE-2019-6802/index.md","name":"CVE-2019-6802","record":{"aliases":["GHSA-mh24-7wvg-v88g","PYSEC-2019-113"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python package server","requires_auth":"none","summary":"Attackers can inject arbitrary HTTP headers and potentially execute XSS attacks via CRLF injection in URIs on pypiserver.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pypiserver","vendor":"python"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"CRLF Injection in pypiserver 1.2.5 and below allows attackers to set arbitrary HTTP headers and possibly conduct XSS attacks via a %0d%0a in a URI.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2019/CVE-2019-6802.yaml","stars":null,"title":"Pypiserver \u003c1.2.5 - Carriage Return Line Feed Injection"}],"tier":"weaponised"},"has_fix":true,"headline":"CRLF Injection in pypiserver","id":"CVE-2019-6802","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":3,"n_references":1,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2019-6803"},"packages":[{"ecosystem":"PyPI","fixed":["1.2.6"],"introduced":["0"],"last_affected":[],"package":"pypiserver","purl":null,"source":"GHSA-mh24-7wvg-v88g"},{"ecosystem":"PyPI","fixed":["1.2.6"],"introduced":["0"],"last_affected":[],"package":"pypiserver","purl":"pkg:pypi/pypiserver","source":"GHSA-mh24-7wvg-v88g"},{"ecosystem":"PyPI","fixed":["1.2.6"],"introduced":["0"],"last_affected":[],"package":"pypiserver","purl":"pkg:pypi/pypiserver","source":"PYSEC-2019-113"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2019-6800"},"products":["n/a"],"published":"2019-01-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can inject arbitrary HTTP headers and potentially execute XSS attacks via CRLF injection in URIs on pypiserver.","url":"https://insights.sbomify.com/CVE-2019-6802/"}