# CVE-2019-6802: CRLF Injection in pypiserver

> Attackers can inject arbitrary HTTP headers and potentially execute XSS attacks via CRLF injection in URIs on pypiserver.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jan 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-mh24-7wvg-v88g, PYSEC-2019-113

## What is CVE-2019-6802?

CVE-2019-6802 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CRLF Injection in pypiserver 1.2.5 and below allows attackers to set arbitrary HTTP headers and possibly conduct XSS attacks via a %0d%0a in a URI.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2019-6802?

3 open source packages ship an affected version, including pypiserver. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pypiserver` | PyPI | All versions | 1.2.6 |
| `pypiserver` | PyPI | All versions | 1.2.6 |
| `pypiserver` | PyPI | All versions | 1.2.6 |

Products: Python Pypiserver.

## How do I fix CVE-2019-6802?

Upgrade pypiserver to 1.2.6 or later.

## Is CVE-2019-6802 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-6802 exists.

Public exploit code:

- Pypiserver <1.2.5 - Carriage Return Line Feed Injection (nuclei): http/cves/2019/CVE-2019-6802.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-6802 and fix it if it is affected.

What it is: CVE-2019-6802 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-6802 exists.

Affected packages and fixed versions:
- pypiserver (PyPI): affected all versions; fixed in 1.2.6
- pypiserver (PyPI): affected all versions; fixed in 1.2.6
- pypiserver (PyPI): affected all versions; fixed in 1.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-6802/ (Markdown: https://insights.sbomify.com/CVE-2019-6802/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-6802
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-6802
- OSV: https://osv.dev/vulnerability/CVE-2019-6802

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-6802/
Summaries are generated and may contain mistakes; the official description above is the record.
