# CVE-2019-6804: Rundeck Community Edition vulnerable to Cross-site Scripting

> An attacker can execute arbitrary scripts in the Job Edit page of Rundeck, potentially compromising user sessions or data.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jan 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-4262-wr7p-gpcj

## What is CVE-2019-6804?

CVE-2019-6804 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An XSS issue was discovered on the Job Edit page in Rundeck Community Edition before 3.0.13, related to assets/javascripts/workflowStepEditorKO.js and views/execution/_wfitemEdit.gsp.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-6804?

2 open source packages ship an affected version, including org.rundeck:rundeck. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.rundeck:rundeck` | Maven | All versions | 3.0.13 |
| `org.rundeck:rundeck` | Maven | All versions | 3.0.13 |

Products: Pagerduty Rundeck.

## How do I fix CVE-2019-6804?

Upgrade org.rundeck:rundeck to 3.0.13 or later.

## Is CVE-2019-6804 being exploited?

There is no known exploitation of CVE-2019-6804 in the wild and no public exploit code.

Public exploit code:

- Rundeck Community Edition < 3.0.13 - Persistent Cross-Site Scripting (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2022-29186](https://insights.sbomify.com/CVE-2022-29186/): Use of Hard-coded Cryptographic Key in rundeck/rundeck, rundeckpro/enterprise (critical 9.1)
- [CVE-2021-39132](https://insights.sbomify.com/CVE-2021-39132/): YAML deserialization can run untrusted code (high 8.8)
- [CVE-2023-48222](https://insights.sbomify.com/CVE-2023-48222/): Authenticated users can view or delete jobs they do not have authorization for in Rundeck (high 8.1)
- [CVE-2021-41112](https://insights.sbomify.com/CVE-2021-41112/): Missing Authorization in Rundeck (high 8.1)
- [CVE-2022-31044](https://insights.sbomify.com/CVE-2022-31044/): Plaintext Storage of Keys and Passwords in Rundeck and PagerDuty Process Automation (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-6804 and fix it if it is affected.

What it is: CVE-2019-6804 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-6804 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.rundeck:rundeck (Maven): affected all versions; fixed in 3.0.13
- org.rundeck:rundeck (Maven): affected all versions; fixed in 3.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-6804/ (Markdown: https://insights.sbomify.com/CVE-2019-6804/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-6804
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-6804
- OSV: https://osv.dev/vulnerability/CVE-2019-6804

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-6804/
Summaries are generated and may contain mistakes; the official description above is the record.
