CVE-2019-6970 Moodle SSRF Vulnerability
High 7.5
Published
Updated
Check this codebase for CVE-2019-6970 and fix it if it is affected.
What it is: CVE-2019-6970 is a high-severity vulnerability in Moodle Moodle, published on 18 Mar 2019.
Exploitation: There is no known exploitation of CVE-2019-6970 in the wild and no public exploit code.
Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 3.5.0; fixed in 3.5.4
- moodle/moodle (Packagist): affected from 3.5.0; fixed in 3.5.4
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2019-6970/ (Markdown: https://insights.sbomify.com/CVE-2019-6970/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2019-6970?
CVE-2019-6970 is a high-severity vulnerability in Moodle Moodle, published on 18 Mar 2019.
Official description
Moodle 3.5.x before 3.5.4 allows SSRF.
Weakness: CWE-918
Which versions are affected by CVE-2019-6970?
2 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.5.0 | 3.5.4 |
moodle/moodle Packagist | From 3.5.0 | 3.5.4 |
Products include Moodle Moodle.
How do I fix CVE-2019-6970?
Upgrade moodle/moodle to 3.5.4 or later.
Is CVE-2019-6970 being exploited?
There is no known exploitation of CVE-2019-6970 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-vjxx-54vw-q59f, UBUNTU-CVE-2019-6970.