CVE-2019-6975 Uncontrolled Memory Consumption in Django
Attackers can cause denial of service in Django applications by supplying malicious values to the number formatting utility, leading to uncontrolled memory consumption.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-6975?
CVE-2019-6975 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 11 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Django 1.11.x before 1.11.19, 2.0.x before 2.0.11, and 2.1.x before 2.1.6 allows Uncontrolled Memory Consumption via a malicious attacker-supplied value to the django.utils.numberformat.format() function.
Weakness: CWE-770
Which versions are affected by CVE-2019-6975?
7 open source packages ship an affected version, including django and Django. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | From 1.11 | 1.11.19, 2.0.12, 2.1.7 |
django PyPI | From 1.11 | 1.11.19 |
django PyPI | From 2.0 | 2.0.11 |
django PyPI | From 2.1 | 2.1.6 |
Django PyPI | From 1.11 | 1.11.19 |
Django PyPI | From 2.0 | 2.0.11 |
1 more packages
Django PyPI | From 2.1 | 2.1.6 |
Linux distribution packages (3)
python-Django SUSE:OpenStack Cloud 7 | All versions | 1.8.19-3.12.5 |
python-Django1 SUSE:OpenStack Cloud 9 | All versions | 1.11.20-3.3.1 |
python-Django1 SUSE:OpenStack Cloud Crowbar 9 | All versions | 1.11.20-3.3.1 |
Products include Canonical Ubuntu Linux, Djangoproject Django, Fedoraproject Fedora.
How do I fix CVE-2019-6975?
Upgrade django to a fixed version for your release line: 1.11.19, 2.0.12, 2.1.7 or 2.0.11.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2019-6975 being exploited?
There is no known exploitation of CVE-2019-6975 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as ALPINE-CVE-2019-6975, DEBIAN-CVE-2019-6975, GHSA-wh4h-v3f2-r2pp, MGASA-2019-0086, PYSEC-2019-18, SUSE-SU-2019:1215-1 and 3 more.