# CVE-2019-6975: Uncontrolled Memory Consumption in Django

> Attackers can cause denial of service in Django applications by supplying malicious values to the number formatting utility, leading to uncontrolled memory consumption.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Feb 2019
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2019-6975, DEBIAN-CVE-2019-6975, GHSA-wh4h-v3f2-r2pp, MGASA-2019-0086, PYSEC-2019-18, SUSE-SU-2019:1215-1, SUSE-SU-2019:2042-1, UBUNTU-CVE-2019-6975, USN-3890-1

## What is CVE-2019-6975?

CVE-2019-6975 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 11 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Django 1.11.x before 1.11.19, 2.0.x before 2.0.11, and 2.1.x before 2.1.6 allows Uncontrolled Memory Consumption via a malicious attacker-supplied value to the django.utils.numberformat.format() function.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2019-6975?

7 open source packages ship an affected version, including django and Django. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | From 1.11 | 1.11.19, 2.0.12, 2.1.7 |
| `django` | PyPI | From 1.11 | 1.11.19 |
| `django` | PyPI | From 2.0 | 2.0.11 |
| `django` | PyPI | From 2.1 | 2.1.6 |
| `Django` | PyPI | From 1.11 | 1.11.19 |
| `Django` | PyPI | From 2.0 | 2.0.11 |
| `Django` | PyPI | From 2.1 | 2.1.6 |
| `python-Django` | SUSE:OpenStack Cloud 7 | All versions | 1.8.19-3.12.5 |
| `python-Django1` | SUSE:OpenStack Cloud 9 | All versions | 1.11.20-3.3.1 |
| `python-Django1` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 1.11.20-3.3.1 |

Products: Canonical Ubuntu Linux, Djangoproject Django, Fedoraproject Fedora.

## How do I fix CVE-2019-6975?

Upgrade django to a fixed version for your release line: 1.11.19, 2.0.12, 2.1.7 or 2.0.11.

## Is CVE-2019-6975 being exploited?

There is no known exploitation of CVE-2019-6975 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-6975 and fix it if it is affected.

What it is: CVE-2019-6975 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 11 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-6975 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected from 1.11; fixed in 1.11.19, 2.0.12, 2.1.7
- django (PyPI): affected from 1.11; fixed in 1.11.19
- django (PyPI): affected from 2.0; fixed in 2.0.11
- django (PyPI): affected from 2.1; fixed in 2.1.6
- Django (PyPI): affected from 1.11; fixed in 1.11.19
- Django (PyPI): affected from 2.0; fixed in 2.0.11
- Django (PyPI): affected from 2.1; fixed in 2.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-6975/ (Markdown: https://insights.sbomify.com/CVE-2019-6975/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-6975
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-6975
- OSV: https://osv.dev/vulnerability/CVE-2019-6975

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-6975/
Summaries are generated and may contain mistakes; the official description above is the record.
