{"answers":{"affected":"It affects 5 products.","exploited":"There is no known exploitation of CVE-2019-6977 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2019-6977 is a high-severity memory corruption vulnerability in Canonical Ubuntu Linux, published on 27 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-6977 and fix it if it is affected.\n\nWhat it is: CVE-2019-6977 is a high-severity memory corruption vulnerability in Canonical Ubuntu Linux, published on 27 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-6977 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-6977/ (Markdown: https://insights.sbomify.com/CVE-2019-6977/index.md)","id":"CVE-2019-6977","markdown":"https://insights.sbomify.com/CVE-2019-6977/index.md","name":"CVE-2019-6977","record":{"aliases":["ALPINE-CVE-2019-6977","DEBIAN-CVE-2019-6977","GHSA-3jrx-xgc5-h2f9","SUSE-SU-2019:0449-1","UBUNTU-CVE-2019-6977","openSUSE-SU-2024:11852-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"GD Graphics Library","requires_auth":"none","summary":"Heap-based buffer overflow in LibGD allows attackers to execute arbitrary code or cause denial of service via crafted image data.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"libgd","vendor":"libgd"},{"product":"storage_automation_store","vendor":"netapp"},{"product":"php","vendor":"php"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"gdImageColorMatch in gd_color_match.c in the GD Graphics Library (aka LibGD) 2.2.5, as used in the imagecolormatch function in PHP before 5.6.40, 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.1, has a heap-based buffer overflow. This can be exploited by an attacker who is able to trigger imagecolormatch calls with crafted image data.","ecosystems":["SUSE:Linux Enterprise Module for Web and Scripting 12","SUSE:Linux Enterprise Software Development Kit 12 SP3","SUSE:Linux Enterprise Software Development Kit 12 SP4","openSUSE:Tumbleweed"],"exploits":{"exploitdb":1,"first_seen":"2019-02-27","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2019-02-27","kind":"exploitdb","ref":"46677","stars":null,"title":"PHP 7.2 - 'imagecolormatch()' Out of Band Heap Write"},{"date":"2026-08-06T06:39:46Z","kind":"github_poc","ref":"https://github.com/HORKimhab/CVE-2022-31626-CVE-2024-2961-CVE-2019-6977","stars":0,"title":"CVE-2022-31626, CVE-2024-2961, CVE-2019-6977, PHP security research"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2019-6977","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","netapp:storage_automation_store","php:php"],"type":"memory_corruption","year":"2019"},"n_packages":4,"n_references":19,"next":{"headline":"Use after free in n/a","id":"CVE-2019-6978"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Web and Scripting 12","fixed":["5.5.14-109.48.1"],"introduced":["0"],"last_affected":[],"package":"php5","purl":"pkg:rpm/suse/php5\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Web%20and%20Scripting%2012","source":"SUSE-SU-2019:0449-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP3","fixed":["5.5.14-109.48.1"],"introduced":["0"],"last_affected":[],"package":"php5","purl":"pkg:rpm/suse/php5\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP3","source":"SUSE-SU-2019:0449-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP4","fixed":["5.5.14-109.48.1"],"introduced":["0"],"last_affected":[],"package":"php5","purl":"pkg:rpm/suse/php5\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP4","source":"SUSE-SU-2019:0449-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.76-1.1"],"introduced":["0"],"last_affected":[],"package":"perl-GD","purl":"pkg:rpm/opensuse/perl-GD\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11852-1"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2019-6976"},"products":["n/a"],"published":"2019-01-27","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Heap-based buffer overflow in LibGD allows attackers to execute arbitrary code or cause denial of service via crafted image data.","url":"https://insights.sbomify.com/CVE-2019-6977/"}