# CVE-2019-7107: Code injection in InDesign

> Unsafe hyperlink processing in Adobe InDesign allows attackers to execute arbitrary code via malicious documents.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 23 May 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-27r8-6jpp-p76v

## What is CVE-2019-7107?

CVE-2019-7107 is a critical code injection vulnerability in Adobe Indesign, published on 23 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Adobe InDesign versions 14.0.1 and below have an unsafe hyperlink processing vulnerability. Successful exploitation could lead to arbitrary code execution. Fixed in versions 13.1.1 and 14.0.2.

## Which versions are affected by CVE-2019-7107?

It affects 1 product.


Products: Adobe Indesign.

## How do I fix CVE-2019-7107?

No fix has been published for CVE-2019-7107 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-7107 being exploited?

There is no known exploitation of CVE-2019-7107 in the wild and no public exploit code.

## Other vulnerabilities in Adobe Indesign

- [CVE-2017-11302](https://insights.sbomify.com/CVE-2017-11302/): Memory corruption in Adobe InDesign 12.1.0 and earlier versions (critical 9.8)
- [CVE-2016-7886](https://insights.sbomify.com/CVE-2016-7886/): Memory corruption in Adobe InDesign 11.4.1 and earlier, InDesign Server 11.0.0 and earlier (critical 9.8)
- [CVE-2021-36004](https://insights.sbomify.com/CVE-2021-36004/): Adobe InDesign CoolType out of bounds write vulnerability could lead to arbitrary stack manipulation (high 8.8)
- [CVE-2021-21098](https://insights.sbomify.com/CVE-2021-21098/): Adobe InDesign PCX file parsing out-of-bounds write vulnerability could lead to remote code execution (high 8.8)
- [CVE-2021-21099](https://insights.sbomify.com/CVE-2021-21099/): Adobe InDesign PCX file parsing out-of-bounds write vulnerability could lead to remote code execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-7107 and fix it if it is affected.

What it is: CVE-2019-7107 is a critical code injection vulnerability in Adobe Indesign, published on 23 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-7107 in the wild and no public exploit code.

Affected product: Adobe Indesign. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-7107/ (Markdown: https://insights.sbomify.com/CVE-2019-7107/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-7107
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-7107
- OSV: https://osv.dev/vulnerability/CVE-2019-7107

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-7107/
Summaries are generated and may contain mistakes; the official description above is the record.
