# CVE-2019-7139: Magento 2 Community Edition SQLi Vulnerability

> Unauthenticated attackers can execute SQL statements to read arbitrary data from the database, leading to sensitive information disclosure in Magento.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-4j6w-9rf8-hg7r

## What is CVE-2019-7139?

CVE-2019-7139 is a critical SQL injection vulnerability in Magento Magento, published on 10 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An unauthenticated user can execute SQL statements that allow arbitrary read access to the underlying database, which causes sensitive data leakage. This issue is fixed in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2019-7139?

6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | From 2.1.0 | 2.1.18 |
| `magento/community-edition` | Packagist | From 2.1.0 | 2.1.18 |
| `magento/community-edition` | Packagist | From 2.2.0 | 2.2.9 |
| `magento/community-edition` | Packagist | From 2.2.0 | 2.2.9 |
| `magento/community-edition` | Packagist | From 2.3.0 | 2.3.2 |
| `magento/community-edition` | Packagist | From 2.3.0 | 2.3.2 |

Products: Magento Magento.

## How do I fix CVE-2019-7139?

Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.

## Is CVE-2019-7139 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-7139 exists.

Public exploit code:

- Proof-of-Concept (PoC) exploit for CVE-2019-7139, an unauthenticated SQL injection vulnerability in Magento (PRODSECBUG-2198). For educational and security research purposes only. Use with explicit permission from system owners. Includes documentation and mitigations. (github_poc): https://github.com/0xSemZ/Magento-CVE-2019-7139-SQLi-PoC
- Magento - SQL Injection (nuclei): http/cves/2019/CVE-2019-7139.yaml

## Other vulnerabilities in Magento Magento

- [CVE-2020-9664](https://insights.sbomify.com/CVE-2020-9664/): Magento php object injection vulnerability (critical 9.8)
- [CVE-2020-9576](https://insights.sbomify.com/CVE-2020-9576/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9578](https://insights.sbomify.com/CVE-2020-9578/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9579](https://insights.sbomify.com/CVE-2020-9579/): Magento Security mitigation bypass vulnerability (critical 9.8)
- [CVE-2020-9580](https://insights.sbomify.com/CVE-2020-9580/): Magento Security mitigation bypass vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-7139 and fix it if it is affected.

What it is: CVE-2019-7139 is a critical SQL injection vulnerability in Magento Magento, published on 10 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2019-7139 exists.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected from 2.1.0; fixed in 2.1.18
- magento/community-edition (Packagist): affected from 2.1.0; fixed in 2.1.18
- magento/community-edition (Packagist): affected from 2.2.0; fixed in 2.2.9
- magento/community-edition (Packagist): affected from 2.2.0; fixed in 2.2.9
- magento/community-edition (Packagist): affected from 2.3.0; fixed in 2.3.2
- magento/community-edition (Packagist): affected from 2.3.0; fixed in 2.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-7139/ (Markdown: https://insights.sbomify.com/CVE-2019-7139/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-7139
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-7139
- OSV: https://osv.dev/vulnerability/CVE-2019-7139

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-7139/
Summaries are generated and may contain mistakes; the official description above is the record.
