# CVE-2019-7168: Croogo vulnerable to XSS in Blog field

> An attacker can execute arbitrary JavaScript in the Croogo CMS blog field via stored XSS, potentially compromising user sessions.

- **Severity:** Medium 4.8 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Jan 2019
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-9f9r-w3xq-f722

## What is CVE-2019-7168?

CVE-2019-7168 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Jan 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A stored-self XSS exists in Croogo through v3.0.5, allowing an attacker to execute HTML or JavaScript code in a vulnerable Blog field to /admin/nodes/nodes/add/blog.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-7168?

2 open source packages ship an affected version, including croogo/croogo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `croogo/croogo` | Packagist | All versions | 3.0.7 |
| `croogo/croogo` | Packagist | All versions | 3.0.7 |

Products: Croogo Croogo.

## How do I fix CVE-2019-7168?

Upgrade croogo/croogo to 3.0.7 or later.

## Is CVE-2019-7168 being exploited?

There is no known exploitation of CVE-2019-7168 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-29643](https://insights.sbomify.com/CVE-2024-29643/): croogo Host header injection (critical 9.1)
- [CVE-2021-44673](https://insights.sbomify.com/CVE-2021-44673/): Unrestricted Upload of File with Dangerous Type in Croogo (high 8.8)
- [CVE-2024-42718](https://insights.sbomify.com/CVE-2024-42718/): Croogo CMS has a path traversal vulnerability (medium 6.5)
- [CVE-2017-1000510](https://insights.sbomify.com/CVE-2017-1000510/): Cross site scripting in Croogo (medium 5.4)
- [CVE-2019-20789](https://insights.sbomify.com/CVE-2019-20789/): Croos-site scripting in Croogo (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-7168 and fix it if it is affected.

What it is: CVE-2019-7168 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Jan 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-7168 in the wild and no public exploit code.

Affected packages and fixed versions:
- croogo/croogo (Packagist): affected all versions; fixed in 3.0.7
- croogo/croogo (Packagist): affected all versions; fixed in 3.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-7168/ (Markdown: https://insights.sbomify.com/CVE-2019-7168/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-7168
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-7168
- OSV: https://osv.dev/vulnerability/CVE-2019-7168

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-7168/
Summaries are generated and may contain mistakes; the official description above is the record.
