{"answers":{"affected":"2 open source packages ship an affected version, including croogo/croogo. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-7169 in the wild and no public exploit code.","fix":"Upgrade croogo/croogo to 3.0.7 or later.","what":"CVE-2019-7169 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Jan 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-7169 and fix it if it is affected.\n\nWhat it is: CVE-2019-7169 is a medium-severity cross-site scripting vulnerability in n/a, published on 29 Jan 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-7169 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- croogo/croogo (Packagist): affected all versions; fixed in 3.0.7\n- croogo/croogo (Packagist): affected all versions; fixed in 3.0.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-7169/ (Markdown: https://insights.sbomify.com/CVE-2019-7169/index.md)","id":"CVE-2019-7169","markdown":"https://insights.sbomify.com/CVE-2019-7169/index.md","name":"CVE-2019-7169","record":{"aliases":["GHSA-wr5c-4f2h-28m6"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Croogo CMS","requires_auth":"high_privilege","summary":"An attacker can execute arbitrary JavaScript in the admin menu title field, potentially compromising administrator sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"croogo","vendor":"croogo"}],"cvss":{"score":4.8,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A stored-self XSS exists in Croogo through v3.0.5, allowing an attacker to execute HTML or JavaScript code in a vulnerable Title field to /admin/menus/menus/edit/3.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Croogo vulnerable to XSS in title field","id":"CVE-2019-7169","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Croogo vulnerable to XSS in title field","id":"CVE-2019-7170"},"packages":[{"ecosystem":"Packagist","fixed":["3.0.7"],"introduced":["0"],"last_affected":[],"package":"croogo/croogo","purl":null,"source":"GHSA-wr5c-4f2h-28m6"},{"ecosystem":"Packagist","fixed":["3.0.7"],"introduced":["0"],"last_affected":[],"package":"croogo/croogo","purl":"pkg:composer/croogo/croogo","source":"GHSA-wr5c-4f2h-28m6"}],"prev":{"headline":"Croogo vulnerable to XSS in Blog field","id":"CVE-2019-7168"},"products":["n/a"],"published":"2019-01-29","related":[{"cvss_score":9.1,"headline":"croogo Host header injection","id":"CVE-2024-29643","kev_date_added":null,"published":"2025-04-18"},{"cvss_score":8.8,"headline":"Unrestricted Upload of File with Dangerous Type in Croogo","id":"CVE-2021-44673","kev_date_added":null,"published":"2022-03-10"},{"cvss_score":6.5,"headline":"Croogo CMS has a path traversal vulnerability","id":"CVE-2024-42718","kev_date_added":null,"published":"2025-12-26"},{"cvss_score":5.4,"headline":"Cross site scripting in Croogo","id":"CVE-2017-1000510","kev_date_added":null,"published":"2018-02-09"},{"cvss_score":4.8,"headline":"Croos-site scripting in Croogo","id":"CVE-2019-20789","kev_date_added":null,"published":"2020-04-26"},{"cvss_score":4.8,"headline":"Croogo vulnerable to XSS in Blog field","id":"CVE-2019-7168","kev_date_added":null,"published":"2019-01-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"An attacker can execute arbitrary JavaScript in the admin menu title field, potentially compromising administrator sessions.","url":"https://insights.sbomify.com/CVE-2019-7169/"}