{"answers":{"affected":"It affects 5 products.","exploited":"There is no known exploitation of CVE-2019-7397 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2019-7397 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 5 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-7397 and fix it if it is affected.\n\nWhat it is: CVE-2019-7397 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 5 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-7397 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-7397/ (Markdown: https://insights.sbomify.com/CVE-2019-7397/index.md)","id":"CVE-2019-7397","markdown":"https://insights.sbomify.com/CVE-2019-7397/index.md","name":"CVE-2019-7397","record":{"aliases":["DEBIAN-CVE-2019-7397","GHSA-7pxc-hv76-qwg9","JLSEC-2026-838","MGASA-2019-0115","UBUNTU-CVE-2019-7397","openSUSE-SU-2019:0215-1","openSUSE-SU-2019:0235-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"ImageMagick library","requires_auth":"none","summary":"Memory leaks in ImageMagick's PDF writer allow attackers to cause resource exhaustion and denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"graphicsmagick","vendor":"graphicsmagick"},{"product":"imagemagick","vendor":"imagemagick"},{"product":"leap","vendor":"opensuse"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-401","name":"Missing Release of Memory after Effective Lifetime"}],"description":"In ImageMagick before 7.0.8-25 and GraphicsMagick through 1.3.31, several memory leaks exist in WritePDFImage in coders/pdf.c.","ecosystems":["SUSE:Package Hub 15"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2019-7397","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","graphicsmagick:graphicsmagick","imagemagick:imagemagick","opensuse:leap"],"type":"denial_of_service","year":"2019"},"n_packages":1,"n_references":8,"next":{"headline":"Denial of service in n/a","id":"CVE-2019-7398"},"packages":[{"ecosystem":"SUSE:Package Hub 15","fixed":["1.3.29-bp150.2.15.1"],"introduced":["0"],"last_affected":[],"package":"GraphicsMagick","purl":"pkg:rpm/suse/GraphicsMagick\u0026distro=SUSE%20Package%20Hub%2015","source":"openSUSE-SU-2019:0235-1"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2019-7396"},"products":["n/a"],"published":"2019-02-05","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Memory leaks in ImageMagick's PDF writer allow attackers to cause resource exhaustion and denial of service.","url":"https://insights.sbomify.com/CVE-2019-7397/"}