{"answers":{"affected":"It affects 4 products.","exploited":"There is no known exploitation of CVE-2019-7524 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2019-7524 is a high-severity memory corruption vulnerability in Canonical Ubuntu Linux, published on 28 Mar 2019. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-7524 and fix it if it is affected.\n\nWhat it is: CVE-2019-7524 is a high-severity memory corruption vulnerability in Canonical Ubuntu Linux, published on 28 Mar 2019. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-7524 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-7524/ (Markdown: https://insights.sbomify.com/CVE-2019-7524/index.md)","id":"CVE-2019-7524","markdown":"https://insights.sbomify.com/CVE-2019-7524/index.md","name":"CVE-2019-7524","record":{"aliases":["ALPINE-CVE-2019-7524","DEBIAN-CVE-2019-7524","DLA-1736-1","DSA-4418-1","GHSA-64hp-rrrv-2xwx","MGASA-2019-0141","SUSE-SU-2019:0876-1","UBUNTU-CVE-2019-7524","USN-3928-1","openSUSE-SU-2019:1212-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Dovecot mail server","requires_auth":"low_privilege","summary":"A local attacker can exploit a buffer overflow in Dovecot's indexer-worker to elevate privileges to root.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"dovecot","vendor":"dovecot"},{"product":"leap","vendor":"opensuse"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.0/AC:L/AV:L/A:H/C:H/I:H/PR:L/S:C/UI:N","version":"3.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"In Dovecot before 2.2.36.3 and 2.3.x before 2.3.5.1, a local attacker can cause a buffer overflow in the indexer-worker process, which can be used to elevate to root. This occurs because of missing checks in the fts and pop3-uidl components.","ecosystems":["SUSE:Linux Enterprise Module for Server Applications 15","openSUSE:Leap 15.0"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2019-7524","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","dovecot:dovecot","opensuse:leap"],"type":"memory_corruption","year":"2019"},"n_packages":2,"n_references":13,"next":{"headline":"Information disclosure in n/a","id":"CVE-2019-7535"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Server Applications 15","fixed":["2.3.3-4.10.1"],"introduced":["0"],"last_affected":[],"package":"dovecot23","purl":"pkg:rpm/suse/dovecot23\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Server%20Applications%2015","source":"SUSE-SU-2019:0876-1"},{"ecosystem":"openSUSE:Leap 15.0","fixed":["2.3.3-lp150.8.2"],"introduced":["0"],"last_affected":[],"package":"dovecot23","purl":"pkg:rpm/opensuse/dovecot23\u0026distro=openSUSE%20Leap%2015.0","source":"openSUSE-SU-2019:1212-1"}],"prev":{"headline":"Auth bypass in Email Security Appliance","id":"CVE-2019-7489"},"products":["n/a"],"published":"2019-03-28","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"A local attacker can exploit a buffer overflow in Dovecot's indexer-worker to elevate privileges to root.","url":"https://insights.sbomify.com/CVE-2019-7524/"}