CVE-2019-7611 Improper Access Control in Elasticsearch
Attackers can bypass permission checks on specific endpoints to gain unauthorized access to restricted indices when Field and Document Level Security are disabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-7611?
CVE-2019-7611 is a high-severity missing authorization vulnerability in Elastic Elasticsearch, published on 25 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A permission issue was found in Elasticsearch versions before 5.6.15 and 6.6.1 when Field Level Security and Document Level Security are disabled and the _aliases, _shrink, or _split endpoints are used . If the elasticsearch.yml file has xpack.security.dls_fls.enabled set to false, certain permission checks are skipped when users perform one of the actions mentioned above, to make existing data available under a new index/alias name. This could result in an attacker gaining additional permissions against a restricted index.
Weakness: CWE-284
Which versions are affected by CVE-2019-7611?
4 open source packages ship an affected version, including org.elasticsearch:elasticsearch. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.elasticsearch:elasticsearch Maven | All versions | 5.6.15 |
org.elasticsearch:elasticsearch Maven | All versions | 5.6.15 |
org.elasticsearch:elasticsearch Maven | From 6.0.0 | 6.6.1 |
org.elasticsearch:elasticsearch Maven | From 6.0.0 | 6.6.1 |
Products include Elastic Elasticsearch.
How do I fix CVE-2019-7611?
Upgrade org.elasticsearch:elasticsearch to a fixed version for your release line: 5.6.15 or 6.6.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2019-7611 being exploited?
There is no known exploitation of CVE-2019-7611 in the wild and no public exploit code.
Other vulnerabilities in Elastic Elasticsearch
- CVE-2015-1427 Elasticsearch Groovy Scripting Engine Remote Code Execution
- CVE-2014-3120 Elasticsearch Remote Code Execution
- CVE-2015-5377 Code injection in n/a
- CVE-2026-72649 Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution
- CVE-2026-72642 Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process
Sources
Also known as GHSA-fj32-6v7m-57pg.