# CVE-2019-7611: Improper Access Control in Elasticsearch

> Attackers can bypass permission checks on specific endpoints to gain unauthorized access to restricted indices when Field and Document Level Security are disabled.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-fj32-6v7m-57pg

## What is CVE-2019-7611?

CVE-2019-7611 is a high-severity missing authorization vulnerability in Elastic Elasticsearch, published on 25 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A permission issue was found in Elasticsearch versions before 5.6.15 and 6.6.1 when Field Level Security and Document Level Security are disabled and the _aliases, _shrink, or _split endpoints are used . If the elasticsearch.yml file has xpack.security.dls_fls.enabled set to false, certain permission checks are skipped when users perform one of the actions mentioned above, to make existing data available under a new index/alias name. This could result in an attacker gaining additional permissions against a restricted index.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2019-7611?

4 open source packages ship an affected version, including org.elasticsearch:elasticsearch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch:elasticsearch` | Maven | All versions | 5.6.15 |
| `org.elasticsearch:elasticsearch` | Maven | All versions | 5.6.15 |
| `org.elasticsearch:elasticsearch` | Maven | From 6.0.0 | 6.6.1 |
| `org.elasticsearch:elasticsearch` | Maven | From 6.0.0 | 6.6.1 |

Products: Elastic Elasticsearch.

## How do I fix CVE-2019-7611?

Upgrade org.elasticsearch:elasticsearch to a fixed version for your release line: 5.6.15 or 6.6.1.

## Is CVE-2019-7611 being exploited?

There is no known exploitation of CVE-2019-7611 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2015-1427](https://insights.sbomify.com/CVE-2015-1427/): Elasticsearch Groovy Scripting Engine Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2014-3120](https://insights.sbomify.com/CVE-2014-3120/): Elasticsearch Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-7611 and fix it if it is affected.

What it is: CVE-2019-7611 is a high-severity missing authorization vulnerability in Elastic Elasticsearch, published on 25 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-7611 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 5.6.15
- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 5.6.15
- org.elasticsearch:elasticsearch (Maven): affected from 6.0.0; fixed in 6.6.1
- org.elasticsearch:elasticsearch (Maven): affected from 6.0.0; fixed in 6.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-7611/ (Markdown: https://insights.sbomify.com/CVE-2019-7611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-7611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-7611
- OSV: https://osv.dev/vulnerability/CVE-2019-7611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-7611/
Summaries are generated and may contain mistakes; the official description above is the record.
