CVE-2019-7614 Concurrent Execution using Shared Resource with Improper Synchronization in Elasticsearch

Medium 5.9 Published Updated

An attacker can exploit a race condition in Elasticsearch response headers to access sensitive data from other users' requests.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-7614?

CVE-2019-7614 is a medium-severity vulnerability in Elastic Elasticsearch, published on 30 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A race condition flaw was found in the response headers Elasticsearch versions before 7.2.1 and 6.8.2 returns to a request. On a system with multiple users submitting requests, it could be possible for an attacker to gain access to response header containing sensitive data from another user.

Weakness: CWE-362

Which versions are affected by CVE-2019-7614?

4 open source packages ship an affected version, including org.elasticsearch:elasticsearch. It affects 1 product.

PackageAffectedFixed in
org.elasticsearch:elasticsearch MavenAll versions6.8.2
org.elasticsearch:elasticsearch MavenAll versions6.8.2
org.elasticsearch:elasticsearch MavenFrom 7.0.07.2.1
org.elasticsearch:elasticsearch MavenFrom 7.0.07.2.1

Products include Elastic Elasticsearch.

How do I fix CVE-2019-7614?

Upgrade org.elasticsearch:elasticsearch to a fixed version for your release line: 6.8.2 or 7.2.1.

Is CVE-2019-7614 being exploited?

There is no known exploitation of CVE-2019-7614 in the wild and no public exploit code.

All Elastic Elasticsearch vulnerabilities

Sources

Also known as GHSA-jqm6-m3j3-8gg9.

Is CVE-2019-7614 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free