{"answers":{"affected":"4 open source packages ship an affected version, including org.elasticsearch:elasticsearch. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-7614 in the wild and no public exploit code.","fix":"Upgrade org.elasticsearch:elasticsearch to a fixed version for your release line: 6.8.2 or 7.2.1.","what":"CVE-2019-7614 is a medium-severity vulnerability in Elastic Elasticsearch, published on 30 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-7614 and fix it if it is affected.\n\nWhat it is: CVE-2019-7614 is a medium-severity vulnerability in Elastic Elasticsearch, published on 30 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-7614 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 6.8.2\n- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 6.8.2\n- org.elasticsearch:elasticsearch (Maven): affected from 7.0.0; fixed in 7.2.1\n- org.elasticsearch:elasticsearch (Maven): affected from 7.0.0; fixed in 7.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-7614/ (Markdown: https://insights.sbomify.com/CVE-2019-7614/index.md)","id":"CVE-2019-7614","markdown":"https://insights.sbomify.com/CVE-2019-7614/index.md","name":"CVE-2019-7614","record":{"aliases":["GHSA-jqm6-m3j3-8gg9"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Elasticsearch search engine","requires_auth":"none","summary":"An attacker can exploit a race condition in Elasticsearch response headers to access sensitive data from other users' requests.","user_interaction":"not_required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"elastic","cpe":[{"product":"elasticsearch","vendor":"elastic"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-362","name":"Concurrent Execution using Shared Resource with Improper Synchronization"}],"description":"A race condition flaw was found in the response headers Elasticsearch versions before 7.2.1 and 6.8.2 returns to a request. On a system with multiple users submitting requests, it could be possible for an attacker to gain access to response header containing sensitive data from another user.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Concurrent Execution using Shared Resource with Improper Synchronization in Elasticsearch","id":"CVE-2019-7614","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"elastic:elasticsearch","products":["elastic:elasticsearch"],"type":"race_condition","year":"2019"},"n_packages":4,"n_references":1,"next":{"headline":"Elastic APM agent for Ruby vulnerable to Improper Certificate Validation","id":"CVE-2019-7615"},"packages":[{"ecosystem":"Maven","fixed":["6.8.2"],"introduced":["0"],"last_affected":[],"package":"org.elasticsearch:elasticsearch","purl":null,"source":"GHSA-jqm6-m3j3-8gg9"},{"ecosystem":"Maven","fixed":["6.8.2"],"introduced":["0"],"last_affected":[],"package":"org.elasticsearch:elasticsearch","purl":"pkg:maven/org.elasticsearch/elasticsearch","source":"GHSA-jqm6-m3j3-8gg9"},{"ecosystem":"Maven","fixed":["7.2.1"],"introduced":["7.0.0"],"last_affected":[],"package":"org.elasticsearch:elasticsearch","purl":null,"source":"GHSA-jqm6-m3j3-8gg9"},{"ecosystem":"Maven","fixed":["7.2.1"],"introduced":["7.0.0"],"last_affected":[],"package":"org.elasticsearch:elasticsearch","purl":"pkg:maven/org.elasticsearch/elasticsearch","source":"GHSA-jqm6-m3j3-8gg9"}],"prev":{"headline":"Winlogbeat versions before 5.6.16 and 6.6.2 had an insufficient logging flaw.","id":"CVE-2019-7613"},"products":["Elasticsearch"],"published":"2019-07-30","related":[{"cvss_score":9.8,"headline":"Elasticsearch Groovy Scripting Engine Remote Code Execution","id":"CVE-2015-1427","kev_date_added":"2022-03-25","published":"2015-02-17"},{"cvss_score":8.1,"headline":"Elasticsearch Remote Code Execution","id":"CVE-2014-3120","kev_date_added":"2022-03-25","published":"2014-07-28"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2015-5377","kev_date_added":null,"published":"2018-03-06"},{"cvss_score":8.8,"headline":"Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution","id":"CVE-2026-72649","kev_date_added":null,"published":"2026-09-01"},{"cvss_score":8.8,"headline":"Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process","id":"CVE-2026-72642","kev_date_added":null,"published":"2026-08-13"},{"cvss_score":8.8,"headline":"Privilege Escalation Flaw in Elasticsearch","id":"CVE-2020-7014","kev_date_added":null,"published":"2020-06-03"},{"cvss_score":8.8,"headline":"Improper Privilege Management in Elasticsearch","id":"CVE-2020-7009","kev_date_added":null,"published":"2020-03-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Elastic"]},"summary":"An attacker can exploit a race condition in Elasticsearch response headers to access sensitive data from other users' requests.","url":"https://insights.sbomify.com/CVE-2019-7614/"}