{"answers":{"affected":"2 open source packages ship an affected version, including elastic-apm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-7615 in the wild and no public exploit code.","fix":"Upgrade elastic-apm to 2.9.0 or later.","what":"CVE-2019-7615 is a high-severity vulnerability in Elastic APM agent for Ruby, published on 30 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-7615 and fix it if it is affected.\n\nWhat it is: CVE-2019-7615 is a high-severity vulnerability in Elastic APM agent for Ruby, published on 30 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-7615 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- elastic-apm (RubyGems): affected all versions; fixed in 2.9.0\n- elastic-apm (RubyGems): affected all versions; fixed in 2.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-7615/ (Markdown: https://insights.sbomify.com/CVE-2019-7615/index.md)","id":"CVE-2019-7615","markdown":"https://insights.sbomify.com/CVE-2019-7615/index.md","name":"CVE-2019-7615","record":{"aliases":["GHSA-35j2-p8fh-x966"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Ruby APM agent","requires_auth":"none","summary":"Attackers can intercept traffic via man-in-the-middle attacks if custom CA certificates are configured, bypassing TLS validation in the Ruby APM agent.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"elastic","cpe":[{"product":"apm-agent-ruby","vendor":"elastic"}],"cvss":{"score":7.4,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"A TLS certificate validation flaw was found in Elastic APM agent for Ruby versions before 2.9.0. When specifying a trusted server CA certificate via the 'server_ca_cert' setting, the Ruby agent would not properly verify the certificate returned by the APM server. This could result in a man in the middle style attack against the Ruby agent.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Elastic APM agent for Ruby vulnerable to Improper Certificate Validation","id":"CVE-2019-7615","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"security_feature_bypass","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Server-side request forgery in Kibana","id":"CVE-2019-7616"},"packages":[{"ecosystem":"RubyGems","fixed":["2.9.0"],"introduced":["0"],"last_affected":[],"package":"elastic-apm","purl":null,"source":"GHSA-35j2-p8fh-x966"},{"ecosystem":"RubyGems","fixed":["2.9.0"],"introduced":["0"],"last_affected":[],"package":"elastic-apm","purl":"pkg:gem/elastic-apm","source":"GHSA-35j2-p8fh-x966"}],"prev":{"headline":"Concurrent Execution using Shared Resource with Improper Synchronization in Elasticsearch","id":"CVE-2019-7614"},"products":["Elastic APM agent for Ruby"],"published":"2019-07-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Elastic"]},"summary":"Attackers can intercept traffic via man-in-the-middle attacks if custom CA certificates are configured, bypassing TLS validation in the Ruby APM agent.","url":"https://insights.sbomify.com/CVE-2019-7615/"}