# CVE-2019-7615: Elastic APM agent for Ruby vulnerable to Improper Certificate Validation

> Attackers can intercept traffic via man-in-the-middle attacks if custom CA certificates are configured, bypassing TLS validation in the Ruby APM agent.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-35j2-p8fh-x966

## What is CVE-2019-7615?

CVE-2019-7615 is a high-severity vulnerability in Elastic APM agent for Ruby, published on 30 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A TLS certificate validation flaw was found in Elastic APM agent for Ruby versions before 2.9.0. When specifying a trusted server CA certificate via the 'server_ca_cert' setting, the Ruby agent would not properly verify the certificate returned by the APM server. This could result in a man in the middle style attack against the Ruby agent.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2019-7615?

2 open source packages ship an affected version, including elastic-apm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elastic-apm` | RubyGems | All versions | 2.9.0 |
| `elastic-apm` | RubyGems | All versions | 2.9.0 |

Products: Elastic Apm-Agent-Ruby.

## How do I fix CVE-2019-7615?

Upgrade elastic-apm to 2.9.0 or later.

## Is CVE-2019-7615 being exploited?

There is no known exploitation of CVE-2019-7615 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-7615 and fix it if it is affected.

What it is: CVE-2019-7615 is a high-severity vulnerability in Elastic APM agent for Ruby, published on 30 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-7615 in the wild and no public exploit code.

Affected packages and fixed versions:
- elastic-apm (RubyGems): affected all versions; fixed in 2.9.0
- elastic-apm (RubyGems): affected all versions; fixed in 2.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-7615/ (Markdown: https://insights.sbomify.com/CVE-2019-7615/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-7615
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-7615
- OSV: https://osv.dev/vulnerability/CVE-2019-7615

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-7615/
Summaries are generated and may contain mistakes; the official description above is the record.
