{"answers":{"affected":"3 open source packages ship an affected version, including elastic-apm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-7617 in the wild and no public exploit code.","fix":"Upgrade elastic-apm to 5.1.0 or later.","what":"CVE-2019-7617 is a high-severity server-side request forgery vulnerability in Elastic APM agent for Python, published on 22 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-7617 and fix it if it is affected.\n\nWhat it is: CVE-2019-7617 is a high-severity server-side request forgery vulnerability in Elastic APM agent for Python, published on 22 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-7617 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- elastic-apm (PyPI): affected all versions; fixed in 5.1.0\n- elastic-apm (PyPI): affected all versions; fixed in 5.1.0\n- elastic-apm (PyPI): affected all versions; fixed in 5.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-7617/ (Markdown: https://insights.sbomify.com/CVE-2019-7617/index.md)","id":"CVE-2019-7617","markdown":"https://insights.sbomify.com/CVE-2019-7617/index.md","name":"CVE-2019-7617","record":{"aliases":["GHSA-22jh-6gx8-f944","PYSEC-2019-178"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Elastic APM Python agent","requires_auth":"none","summary":"Attackers can redirect APM data to a malicious proxy when the Python agent runs as a CGI script with controlled headers.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"elastic","cpe":[{"product":"apm_agent","vendor":"elastic"}],"cvss":{"score":7.2,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"When the Elastic APM agent for Python versions before 5.1.0 is run as a CGI script, there is a variable name clash flaw if a remote attacker can control the proxy header. This could result in an attacker redirecting collected APM data to a proxy of their choosing.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Elastic APM agent for Python client CGI proxy redirection flaw","id":"CVE-2019-7617","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2019"},"n_packages":3,"n_references":2,"next":{"headline":"Path traversal in Elastic Code","id":"CVE-2019-7618"},"packages":[{"ecosystem":"PyPI","fixed":["5.1.0"],"introduced":["0"],"last_affected":[],"package":"elastic-apm","purl":null,"source":"GHSA-22jh-6gx8-f944"},{"ecosystem":"PyPI","fixed":["5.1.0"],"introduced":["0"],"last_affected":[],"package":"elastic-apm","purl":"pkg:pypi/elastic-apm","source":"GHSA-22jh-6gx8-f944"},{"ecosystem":"PyPI","fixed":["5.1.0"],"introduced":["0"],"last_affected":[],"package":"elastic-apm","purl":"pkg:pypi/elastic-apm","source":"PYSEC-2019-178"}],"prev":{"headline":"Server-side request forgery in Kibana","id":"CVE-2019-7616"},"products":["Elastic APM agent for Python"],"published":"2019-08-22","related":[{"cvss_score":7.8,"headline":"APM Java Agent Local Privilege Escalation","id":"CVE-2021-37941","kev_date_added":null,"published":"2021-12-08"},{"cvss_score":2.4,"headline":"Information Disclosure in go.elastic.co/apm","id":"CVE-2021-22133","kev_date_added":null,"published":"2021-02-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Elastic"]},"summary":"Attackers can redirect APM data to a malicious proxy when the Python agent runs as a CGI script with controlled headers.","url":"https://insights.sbomify.com/CVE-2019-7617/"}