# CVE-2019-7617: Elastic APM agent for Python client CGI proxy redirection flaw

> Attackers can redirect APM data to a malicious proxy when the Python agent runs as a CGI script with controlled headers.

- **Severity:** High 7.2 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Aug 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-22jh-6gx8-f944, PYSEC-2019-178

## What is CVE-2019-7617?

CVE-2019-7617 is a high-severity server-side request forgery vulnerability in Elastic APM agent for Python, published on 22 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When the Elastic APM agent for Python versions before 5.1.0 is run as a CGI script, there is a variable name clash flaw if a remote attacker can control the proxy header. This could result in an attacker redirecting collected APM data to a proxy of their choosing.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2019-7617?

3 open source packages ship an affected version, including elastic-apm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elastic-apm` | PyPI | All versions | 5.1.0 |
| `elastic-apm` | PyPI | All versions | 5.1.0 |
| `elastic-apm` | PyPI | All versions | 5.1.0 |

Products: Elastic Apm Agent.

## How do I fix CVE-2019-7617?

Upgrade elastic-apm to 5.1.0 or later.

## Is CVE-2019-7617 being exploited?

There is no known exploitation of CVE-2019-7617 in the wild and no public exploit code.

## Other vulnerabilities in Elastic APM agent for Python

- [CVE-2021-37941](https://insights.sbomify.com/CVE-2021-37941/): APM Java Agent Local Privilege Escalation (high 7.8)
- [CVE-2021-22133](https://insights.sbomify.com/CVE-2021-22133/): Information Disclosure in go.elastic.co/apm (low 2.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-7617 and fix it if it is affected.

What it is: CVE-2019-7617 is a high-severity server-side request forgery vulnerability in Elastic APM agent for Python, published on 22 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-7617 in the wild and no public exploit code.

Affected packages and fixed versions:
- elastic-apm (PyPI): affected all versions; fixed in 5.1.0
- elastic-apm (PyPI): affected all versions; fixed in 5.1.0
- elastic-apm (PyPI): affected all versions; fixed in 5.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-7617/ (Markdown: https://insights.sbomify.com/CVE-2019-7617/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-7617
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-7617
- OSV: https://osv.dev/vulnerability/CVE-2019-7617

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-7617/
Summaries are generated and may contain mistakes; the official description above is the record.
