# CVE-2019-7644: Critical severity vulnerability that affects Auth0-WCF-Service-JWT

> An attacker can forge arbitrary JWT tokens by extracting the expected signature from error messages, bypassing authentication in applications using this library.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-qpvx-gpqm-g98j

## What is CVE-2019-7644?

CVE-2019-7644 is a critical vulnerability in n/a, published on 11 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Auth0 Auth0-WCF-Service-JWT before 1.0.4 leaks the expected JWT signature in an error message when it cannot successfully validate the JWT signature. If this error message is presented to an attacker, they can forge an arbitrary JWT token that will be accepted by the vulnerable application.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2019-7644?

2 open source packages ship an affected version, including Auth0-WCF-Service-JWT. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Auth0-WCF-Service-JWT` | NuGet | All versions | 1.0.4 |
| `Auth0-WCF-Service-JWT` | NuGet | All versions | 1.0.4 |

Products: Auth0 Auth0-Wcf-Service-Jwt.

## How do I fix CVE-2019-7644?

Upgrade Auth0-WCF-Service-JWT to 1.0.4 or later.

## Is CVE-2019-7644 being exploited?

There is no known exploitation of CVE-2019-7644 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-7644 and fix it if it is affected.

What it is: CVE-2019-7644 is a critical vulnerability in n/a, published on 11 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-7644 in the wild and no public exploit code.

Affected packages and fixed versions:
- Auth0-WCF-Service-JWT (NuGet): affected all versions; fixed in 1.0.4
- Auth0-WCF-Service-JWT (NuGet): affected all versions; fixed in 1.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-7644/ (Markdown: https://insights.sbomify.com/CVE-2019-7644/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-7644
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-7644
- OSV: https://osv.dev/vulnerability/CVE-2019-7644

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-7644/
Summaries are generated and may contain mistakes; the official description above is the record.
