# CVE-2019-7725: Deserialization of Untrusted Data in NukeViet

> An attacker can achieve remote code execution by sending a maliciously crafted nvloginhash cookie to the NukeViet CMS.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-32wr-8wxm-852c

## What is CVE-2019-7725?

CVE-2019-7725 is a critical unsafe deserialization vulnerability in n/a, published on 31 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

includes/core/is_user.php in NukeViet before 4.3.04 deserializes the untrusted nvloginhash cookie (i.e., the code relies on PHP's serialization format when JSON can be used to eliminate the risk).

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2019-7725?

2 open source packages ship an affected version, including nukeviet/nukeviet. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nukeviet/nukeviet` | Packagist | All versions | 4.3.04 |
| `nukeviet/nukeviet` | Packagist | All versions | 4.3.04 |

Products: Nukeviet Nukeviet.

## How do I fix CVE-2019-7725?

Upgrade nukeviet/nukeviet to 4.3.04 or later.

## Is CVE-2019-7725 being exploited?

There is no known exploitation of CVE-2019-7725 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-21808](https://insights.sbomify.com/CVE-2020-21808/): NukeViet SQL Injection vulnerability via topicsid parameter (critical 9.8)
- [CVE-2020-21809](https://insights.sbomify.com/CVE-2020-21809/): NukeViet SQL Injection vulnerability (critical 9.8)
- [CVE-2019-7726](https://insights.sbomify.com/CVE-2019-7726/): SQL Injection in NukeViet (critical 9.8)
- [CVE-2020-13155](https://insights.sbomify.com/CVE-2020-13155/): NukeViet Cross-Site Request Forgery (CSRF) (high 8.8)
- [CVE-2020-13156](https://insights.sbomify.com/CVE-2020-13156/): NukeViet Cross-Site Request Forgery (CSRF) (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-7725 and fix it if it is affected.

What it is: CVE-2019-7725 is a critical unsafe deserialization vulnerability in n/a, published on 31 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-7725 in the wild and no public exploit code.

Affected packages and fixed versions:
- nukeviet/nukeviet (Packagist): affected all versions; fixed in 4.3.04
- nukeviet/nukeviet (Packagist): affected all versions; fixed in 4.3.04

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-7725/ (Markdown: https://insights.sbomify.com/CVE-2019-7725/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-7725
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-7725
- OSV: https://osv.dev/vulnerability/CVE-2019-7725

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-7725/
Summaries are generated and may contain mistakes; the official description above is the record.
