CVE-2019-7849 Magento 2 Community Edition Session Fixation Check
Attackers can hijack user sessions due to inadequate validation in third-party checkout modules, requiring an upgrade to secure the Magento platform.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-7849?
CVE-2019-7849 is a high-severity authentication bypass vulnerability in Magento Magento, published on 2 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A defense-in-depth check was added to mitigate inadequate session validation handling by 3rd party checkout modules. This impacts Magento 1.x prior to 1.9.4.2, Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9 and Magento 2.3 prior to 2.3.2.
Weakness: CWE-384
Which versions are affected by CVE-2019-7849?
6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.1.0 | 2.1.18 |
magento/community-edition Packagist | From 2.1.0 | 2.1.18 |
magento/community-edition Packagist | From 2.2.0 | 2.2.9 |
magento/community-edition Packagist | From 2.2.0 | 2.2.9 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2 |
Products include Magento Magento.
How do I fix CVE-2019-7849?
Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2019-7849 being exploited?
There is no known exploitation of CVE-2019-7849 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-v797-hfv8-v2xm.