# CVE-2019-7855: Magento 2 Community Cryptographic Flaw

> An unauthenticated attacker can discover an invariant used in gift card generation due to a cryptographic flaw in Magento.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Aug 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-2w26-gmqm-mc5p

## What is CVE-2019-7855?

CVE-2019-7855 is a medium-severity vulnerability in Magento Magento, published on 2 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A cryptograhic flaw in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2 could be abused by an unauthenticated user to discover an invariant used in gift card generation.

Weakness: CWE-338 (Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG))

## Which versions are affected by CVE-2019-7855?

6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | From 2.1.0 | 2.1.18 |
| `magento/community-edition` | Packagist | From 2.1.0 | 2.1.18 |
| `magento/community-edition` | Packagist | From 2.2.0 | 2.2.9 |
| `magento/community-edition` | Packagist | From 2.2.0 | 2.2.9 |
| `magento/community-edition` | Packagist | From 2.3.0 | 2.3.2 |
| `magento/community-edition` | Packagist | From 2.3.0 | 2.3.2 |

Products: Magento Magento.

## How do I fix CVE-2019-7855?

Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.

## Is CVE-2019-7855 being exploited?

There is no known exploitation of CVE-2019-7855 in the wild and no public exploit code.

## Other vulnerabilities in Magento Magento

- [CVE-2020-9664](https://insights.sbomify.com/CVE-2020-9664/): Magento php object injection vulnerability (critical 9.8)
- [CVE-2020-9576](https://insights.sbomify.com/CVE-2020-9576/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9578](https://insights.sbomify.com/CVE-2020-9578/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9579](https://insights.sbomify.com/CVE-2020-9579/): Magento Security mitigation bypass vulnerability (critical 9.8)
- [CVE-2020-9580](https://insights.sbomify.com/CVE-2020-9580/): Magento Security mitigation bypass vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-7855 and fix it if it is affected.

What it is: CVE-2019-7855 is a medium-severity vulnerability in Magento Magento, published on 2 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-7855 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected from 2.1.0; fixed in 2.1.18
- magento/community-edition (Packagist): affected from 2.1.0; fixed in 2.1.18
- magento/community-edition (Packagist): affected from 2.2.0; fixed in 2.2.9
- magento/community-edition (Packagist): affected from 2.2.0; fixed in 2.2.9
- magento/community-edition (Packagist): affected from 2.3.0; fixed in 2.3.2
- magento/community-edition (Packagist): affected from 2.3.0; fixed in 2.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-7855/ (Markdown: https://insights.sbomify.com/CVE-2019-7855/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-7855
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-7855
- OSV: https://osv.dev/vulnerability/CVE-2019-7855

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-7855/
Summaries are generated and may contain mistakes; the official description above is the record.
