CVE-2019-7858 Magento 2 Community Edition Cryptographic Flaw

High 7.5 Published Updated

Attackers can brute-force sensitive information stored with weak cryptography in Magento, leading to potential data exposure.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-7858?

CVE-2019-7858 is a high-severity vulnerability in Magento Magento, published on 2 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A cryptographic flaw in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9 and Magento 2.3 prior to 2.3.2 resulted in storage of sensitive information with an algorithm that is insufficiently resistant to brute force attacks.

Weakness: CWE-327

Which versions are affected by CVE-2019-7858?

6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.

PackageAffectedFixed in
magento/community-edition PackagistFrom 2.1.02.1.18
magento/community-edition PackagistFrom 2.1.02.1.18
magento/community-edition PackagistFrom 2.2.02.2.9
magento/community-edition PackagistFrom 2.2.02.2.9
magento/community-edition PackagistFrom 2.3.02.3.2
magento/community-edition PackagistFrom 2.3.02.3.2

Products include Magento Magento.

How do I fix CVE-2019-7858?

Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.

Is CVE-2019-7858 being exploited?

There is no known exploitation of CVE-2019-7858 in the wild and no public exploit code.

All Magento Magento vulnerabilities

Sources

Also known as GHSA-7h8v-f2g9-39fx.

Is CVE-2019-7858 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free