CVE-2019-7859 Magento 2 Community Edition Path Traversal Vulnerability
Attackers can exploit a path traversal flaw in the WYSIWYG editor to gain unauthorized access to uploaded images.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-7859?
CVE-2019-7859 is a high-severity path traversal vulnerability in Magento Magento, published on 2 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A path traversal vulnerability in the WYSIWYG editor for Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2 could result in unauthorized access to uploaded images due to insufficient access control.
Weakness: CWE-22
Which versions are affected by CVE-2019-7859?
6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.1.0 | 2.1.18 |
magento/community-edition Packagist | From 2.1.0 | 2.1.18 |
magento/community-edition Packagist | From 2.2.0 | 2.2.9 |
magento/community-edition Packagist | From 2.2.0 | 2.2.9 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2 |
Products include Magento Magento.
How do I fix CVE-2019-7859?
Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2019-7859 being exploited?
There is no known exploitation of CVE-2019-7859 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-hqhf-8jgc-h5hx.