CVE-2019-7860 Magento 2 Community Edition Weak PRNG

High 7.5 Published Updated

Attackers can predict security tokens due to weak random number generation in Magento, potentially bypassing security controls.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-7860?

CVE-2019-7860 is a high-severity vulnerability in Magento Magento, published on 2 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A cryptographically weak pseudo-rando number generator is used in multiple security relevant contexts in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2.

Weakness: CWE-338

Which versions are affected by CVE-2019-7860?

6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.

PackageAffectedFixed in
magento/community-edition PackagistFrom 2.1.02.1.18
magento/community-edition PackagistFrom 2.1.02.1.18
magento/community-edition PackagistFrom 2.2.02.2.9
magento/community-edition PackagistFrom 2.2.02.2.9
magento/community-edition PackagistFrom 2.3.02.3.2
magento/community-edition PackagistFrom 2.3.02.3.2

Products include Magento Magento.

How do I fix CVE-2019-7860?

Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.

Is CVE-2019-7860 being exploited?

There is no known exploitation of CVE-2019-7860 in the wild and no public exploit code.

All Magento Magento vulnerabilities

Sources

Also known as GHSA-8v9h-m7pj-hx7c.

Is CVE-2019-7860 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free