CVE-2019-7871 Magento 2 Community Edition Unsafe File Upload
Authenticated users can bypass security protections to upload and execute arbitrary PHP code in Magento 2.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-7871?
CVE-2019-7871 is a high-severity code injection vulnerability in Magento Magento, published on 2 Aug 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A security bypass exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2 that could be abused to execute arbitrary PHP code. An authenticated user can bypass security protections that prevent arbitrary PHP script upload via form data injection.
Weakness: CWE-94
Which versions are affected by CVE-2019-7871?
6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.1.0 | 2.1.18 |
magento/community-edition Packagist | From 2.1.0 | 2.1.18 |
magento/community-edition Packagist | From 2.2.0 | 2.2.9 |
magento/community-edition Packagist | From 2.2.0 | 2.2.9 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2 |
Products include Magento Magento.
How do I fix CVE-2019-7871?
Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2019-7871 being exploited?
There is no known exploitation of CVE-2019-7871 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-v527-6h5r-cfg8.