CVE-2019-7876 Magento 2 Community Edition RCE Vulnerability
Authenticated users with layout privileges can inject malicious code to achieve remote code execution in Magento.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-7876?
CVE-2019-7876 is a high-severity code injection vulnerability in Magento Magento, published on 2 Aug 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with privileges to manipulate layouts can insert a malicious payload into the layout.
Which versions are affected by CVE-2019-7876?
12 open source packages ship an affected version, including magento/community-edition and magento/product-community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.1 | 2.1.18 |
magento/community-edition Packagist | From 2.1 | 2.1.18 |
magento/community-edition Packagist | From 2.2 | 2.2.9 |
magento/community-edition Packagist | From 2.2 | 2.2.9 |
magento/community-edition Packagist | From 2.3 | 2.3.2 |
magento/community-edition Packagist | From 2.3 | 2.3.2 |
6 more packages
magento/product-community-edition Packagist | From 2.1 | 2.1.18 |
magento/product-community-edition Packagist | From 2.1 | 2.1.18 |
magento/product-community-edition Packagist | From 2.2 | 2.2.9 |
magento/product-community-edition Packagist | From 2.2 | 2.2.9 |
magento/product-community-edition Packagist | From 2.3 | 2.3.2 |
magento/product-community-edition Packagist | From 2.3 | 2.3.2 |
Products include Magento Magento.
How do I fix CVE-2019-7876?
Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2019-7876 being exploited?
There is no known exploitation of CVE-2019-7876 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-6qh6-v99h-vh4c.