CVE-2019-7881 Magento 2 Community Edition XSS Vulnerability
Authenticated users can bypass XSS mitigations to escalate privileges to admin level in Magento 2.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-7881?
CVE-2019-7881 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 2 Aug 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A cross-site scripting mitigation bypass exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user to escalate privileges (admin vs. admin XSS attack).
Weakness: CWE-79
Which versions are affected by CVE-2019-7881?
6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.1 | 2.1.18 |
magento/community-edition Packagist | From 2.1 | 2.1.18 |
magento/community-edition Packagist | From 2.2 | 2.2.9 |
magento/community-edition Packagist | From 2.2 | 2.2.9 |
magento/community-edition Packagist | From 2.3 | 2.3.2 |
magento/community-edition Packagist | From 2.3 | 2.3.2 |
Products include Magento Magento.
How do I fix CVE-2019-7881?
Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-7881 being exploited?
There is no known exploitation of CVE-2019-7881 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-7xqv-jgv6-x2h8.