{"answers":{"affected":"6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-7881 in the wild and no public exploit code.","fix":"Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.","what":"CVE-2019-7881 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 2 Aug 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-7881 and fix it if it is affected.\n\nWhat it is: CVE-2019-7881 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 2 Aug 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-7881 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- magento/community-edition (Packagist): affected from 2.1; fixed in 2.1.18\n- magento/community-edition (Packagist): affected from 2.1; fixed in 2.1.18\n- magento/community-edition (Packagist): affected from 2.2; fixed in 2.2.9\n- magento/community-edition (Packagist): affected from 2.2; fixed in 2.2.9\n- magento/community-edition (Packagist): affected from 2.3; fixed in 2.3.2\n- magento/community-edition (Packagist): affected from 2.3; fixed in 2.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-7881/ (Markdown: https://insights.sbomify.com/CVE-2019-7881/index.md)","id":"CVE-2019-7881","markdown":"https://insights.sbomify.com/CVE-2019-7881/index.md","name":"CVE-2019-7881","record":{"aliases":["GHSA-7xqv-jgv6-x2h8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Magento e-commerce platform","requires_auth":"low_privilege","summary":"Authenticated users can bypass XSS mitigations to escalate privileges to admin level in Magento 2.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"adobe","cpe":[{"product":"magento","vendor":"magento"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A cross-site scripting mitigation bypass exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user to escalate privileges (admin vs. admin XSS attack).","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Magento 2 Community Edition XSS Vulnerability","id":"CVE-2019-7881","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"magento:magento","products":["magento:magento"],"type":"xss","year":"2019"},"n_packages":6,"n_references":1,"next":{"headline":"Magento 2 Community Edition XSS Vulnerability","id":"CVE-2019-7882"},"packages":[{"ecosystem":"Packagist","fixed":["2.1.18"],"introduced":["2.1"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-7xqv-jgv6-x2h8"},{"ecosystem":"Packagist","fixed":["2.1.18"],"introduced":["2.1"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-7xqv-jgv6-x2h8"},{"ecosystem":"Packagist","fixed":["2.2.9"],"introduced":["2.2"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-7xqv-jgv6-x2h8"},{"ecosystem":"Packagist","fixed":["2.2.9"],"introduced":["2.2"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-7xqv-jgv6-x2h8"},{"ecosystem":"Packagist","fixed":["2.3.2"],"introduced":["2.3"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-7xqv-jgv6-x2h8"},{"ecosystem":"Packagist","fixed":["2.3.2"],"introduced":["2.3"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-7xqv-jgv6-x2h8"}],"prev":{"headline":"Magento 2 Community Edition XSS Vulnerability","id":"CVE-2019-7880"},"products":["Magento 2"],"published":"2019-08-02","related":[{"cvss_score":9.8,"headline":"Magento php object injection vulnerability","id":"CVE-2020-9664","kev_date_added":null,"published":"2020-07-22"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9576","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9578","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9579","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9580","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9582","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9583","kev_date_added":null,"published":"2020-06-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Authenticated users can bypass XSS mitigations to escalate privileges to admin level in Magento 2.","url":"https://insights.sbomify.com/CVE-2019-7881/"}