CVE-2019-7886 Magento 2 Community Edition Cryptographic Flaw
Weak cryptographic mechanism in Magento 2 allows attackers to bypass security controls by exploiting predictable initialization vectors.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-7886?
CVE-2019-7886 is a high-severity vulnerability in Magento Magento, published on 2 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A cryptograhic flaw exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. A weak cryptograhic mechanism is used to generate the intialization vector in multiple security relevant contexts.
Weakness: CWE-330
Which versions are affected by CVE-2019-7886?
6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.1 | 2.1.18 |
magento/community-edition Packagist | From 2.1 | 2.1.18 |
magento/community-edition Packagist | From 2.2 | 2.2.9 |
magento/community-edition Packagist | From 2.2 | 2.2.9 |
magento/community-edition Packagist | From 2.3 | 2.3.2 |
magento/community-edition Packagist | From 2.3 | 2.3.2 |
Products include Magento Magento.
How do I fix CVE-2019-7886?
Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.
Is CVE-2019-7886 being exploited?
There is no known exploitation of CVE-2019-7886 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-c2gg-rrhc-fvvg.