CVE-2019-7892 Magento 2 Community Edition RCE Vulnerability via SSRF
An authenticated administrator can execute arbitrary code via server-side request forgery in Magento 2.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-7892?
CVE-2019-7892 is a high-severity server-side request forgery vulnerability in Magento Magento, published on 2 Aug 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with administrator privileges to access shipment settings can execute arbitrary code via server-side request forgery.
Weakness: CWE-918
Which versions are affected by CVE-2019-7892?
6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.1 | 2.1.18 |
magento/community-edition Packagist | From 2.1 | 2.1.18 |
magento/community-edition Packagist | From 2.2 | 2.2.9 |
magento/community-edition Packagist | From 2.2 | 2.2.9 |
magento/community-edition Packagist | From 2.3 | 2.3.2 |
magento/community-edition Packagist | From 2.3 | 2.3.2 |
Products include Magento Magento.
How do I fix CVE-2019-7892?
Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2019-7892 being exploited?
There is no known exploitation of CVE-2019-7892 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-w3r8-fxv5-58pp.