CVE-2019-7895 Magento 2 Community Edition RCE Vulnerability

High 7.2 Published Updated

Authenticated admin users can execute arbitrary code via crafted XML layout updates in Magento 2.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-7895?

CVE-2019-7895 is a high-severity code injection vulnerability in Magento Magento, published on 2 Aug 2019. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with admin privileges to layouts can execute arbitrary code through a crafted XML layout update.

Which versions are affected by CVE-2019-7895?

6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.

PackageAffectedFixed in
magento/community-edition PackagistFrom 2.12.1.18
magento/community-edition PackagistFrom 2.12.1.18
magento/community-edition PackagistFrom 2.22.2.9
magento/community-edition PackagistFrom 2.22.2.9
magento/community-edition PackagistFrom 2.32.3.2
magento/community-edition PackagistFrom 2.32.3.2

Products include Magento Magento.

How do I fix CVE-2019-7895?

Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2019-7895 being exploited?

There is no known exploitation of CVE-2019-7895 in the wild and no public exploit code.

All Magento Magento vulnerabilities

Sources

Also known as GHSA-mw5w-cf76-73m8.

Is CVE-2019-7895 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free