CVE-2019-7911 Magento 2 Community Edition Server-Side Request Forgery vulnerability
Authenticated admin users can exploit SSRF to manipulate configuration and execute arbitrary code in Magento.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-7911?
CVE-2019-7911 is a high-severity server-side request forgery vulnerability in Magento Magento, published on 2 Aug 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A server-side request forgery (SSRF) vulnerability exists in Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This can be exploited by an authenticated user with access to the admin panel to manipulate system configuration and execute arbitrary code.
Weakness: CWE-918
Which versions are affected by CVE-2019-7911?
6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.1.0 | 2.1.18 |
magento/community-edition Packagist | From 2.1.0 | 2.1.18 |
magento/community-edition Packagist | From 2.2.0 | 2.2.9 |
magento/community-edition Packagist | From 2.2.0 | 2.2.9 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2 |
Products include Magento Magento.
How do I fix CVE-2019-7911?
Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2019-7911 being exploited?
There is no known exploitation of CVE-2019-7911 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-33cj-w75f-49m2.