# CVE-2019-7912: Magento Filter extension bypass via crafted store configuration keys

> Authenticated admin users can bypass file upload filters to upload and execute malicious files on the server.

- **Severity:** High 7.2 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Aug 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-f8h9-7rpq-7qcc

## What is CVE-2019-7912?

CVE-2019-7912 is a high-severity vulnerability in Magento Magento, published on 2 Aug 2019. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A file upload filter bypass exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This can be exploited by an authenticated user with admin privileges to edit configuration keys to remove file extension filters, potentially resulting in the malicious upload and execution of malicious files on the server.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2019-7912?

6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | From 2.1 | 2.1.18 |
| `magento/community-edition` | Packagist | From 2.1 | 2.1.18 |
| `magento/community-edition` | Packagist | From 2.2 | 2.2.9 |
| `magento/community-edition` | Packagist | From 2.2 | 2.2.9 |
| `magento/community-edition` | Packagist | From 2.3 | 2.3.2 |
| `magento/community-edition` | Packagist | From 2.3 | 2.3.2 |

Products: Magento Magento.

## How do I fix CVE-2019-7912?

Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.

## Is CVE-2019-7912 being exploited?

There is no known exploitation of CVE-2019-7912 in the wild and no public exploit code.

## Other vulnerabilities in Magento Magento

- [CVE-2020-9664](https://insights.sbomify.com/CVE-2020-9664/): Magento php object injection vulnerability (critical 9.8)
- [CVE-2020-9576](https://insights.sbomify.com/CVE-2020-9576/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9578](https://insights.sbomify.com/CVE-2020-9578/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9579](https://insights.sbomify.com/CVE-2020-9579/): Magento Security mitigation bypass vulnerability (critical 9.8)
- [CVE-2020-9580](https://insights.sbomify.com/CVE-2020-9580/): Magento Security mitigation bypass vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-7912 and fix it if it is affected.

What it is: CVE-2019-7912 is a high-severity vulnerability in Magento Magento, published on 2 Aug 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-7912 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected from 2.1; fixed in 2.1.18
- magento/community-edition (Packagist): affected from 2.1; fixed in 2.1.18
- magento/community-edition (Packagist): affected from 2.2; fixed in 2.2.9
- magento/community-edition (Packagist): affected from 2.2; fixed in 2.2.9
- magento/community-edition (Packagist): affected from 2.3; fixed in 2.3.2
- magento/community-edition (Packagist): affected from 2.3; fixed in 2.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-7912/ (Markdown: https://insights.sbomify.com/CVE-2019-7912/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-7912
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-7912
- OSV: https://osv.dev/vulnerability/CVE-2019-7912

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-7912/
Summaries are generated and may contain mistakes; the official description above is the record.
