CVE-2019-7923 Magento 2 Community Edition SSRF vulnerability

High 7.2 Published Updated

Authenticated admin users can exploit an SSRF vulnerability in Magento 2 to manipulate shipment settings and execute arbitrary code.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-7923?

CVE-2019-7923 is a high-severity server-side request forgery vulnerability in Magento Magento, published on 2 Aug 2019. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

A server-side request forgery (SSRF) vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This can be exploited by authenticated user with admin privileges to manipulate shipment settings to execute arbitrary code.

Weakness: CWE-918

Which versions are affected by CVE-2019-7923?

6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.

PackageAffectedFixed in
magento/community-edition PackagistFrom 2.1.02.1.18
magento/community-edition PackagistFrom 2.1.02.1.18
magento/community-edition PackagistFrom 2.2.02.2.9
magento/community-edition PackagistFrom 2.2.02.2.9
magento/community-edition PackagistFrom 2.3.02.3.2
magento/community-edition PackagistFrom 2.3.02.3.2

Products include Magento Magento.

How do I fix CVE-2019-7923?

Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2019-7923 being exploited?

There is no known exploitation of CVE-2019-7923 in the wild and no public exploit code.

All Magento Magento vulnerabilities

Sources

Also known as GHSA-hvcp-jvx5-4pmp.

Is CVE-2019-7923 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free