CVE-2019-7932 Magento 2 Community Edition RCE Vulnerability
Authenticated admin users can execute arbitrary PHP code by creating malicious sitemap files in Magento.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-7932?
CVE-2019-7932 is a high-severity code injection vulnerability in Magento Magento, published on 2 Aug 2019. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A remote code execution vulnerability exists in Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with admin privileges to create sitemaps can execute arbitrary PHP code by creating a malicious sitemap file.
Which versions are affected by CVE-2019-7932?
6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.1 | 2.1.18 |
magento/community-edition Packagist | From 2.1 | 2.1.18 |
magento/community-edition Packagist | From 2.2 | 2.2.9 |
magento/community-edition Packagist | From 2.2 | 2.2.9 |
magento/community-edition Packagist | From 2.3 | 2.3.2 |
magento/community-edition Packagist | From 2.3 | 2.3.2 |
Products include Magento Magento.
How do I fix CVE-2019-7932?
Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2019-7932 being exploited?
There is no known exploitation of CVE-2019-7932 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-969v-mwp3-4mr3.