CVE-2019-7938 Magento 2 Community Edition XSS Vulnerability

Medium 4.8 Published Updated

Authenticated users with catalog price rule privileges can inject malicious JavaScript into the Magento admin panel, potentially leading to session hijacking or further compromise.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2019-7938?

CVE-2019-7938 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 2 Aug 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

A stored cross-site scripting vulnerability exists in the admin panel of Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user with privileges to modify catalog price rules to inject malicious javascript.

Weakness: CWE-79

Which versions are affected by CVE-2019-7938?

16 open source packages ship an affected version, including magento/community-edition, magento/magento1ce and magento/magento1ee. It affects 1 product.

PackageAffectedFixed in
magento/community-edition PackagistFrom 2.1.02.1.18
magento/community-edition PackagistFrom 2.1.02.1.18
magento/community-edition PackagistFrom 2.2.02.2.9
magento/community-edition PackagistFrom 2.2.02.2.9
magento/community-edition PackagistFrom 2.3.02.3.2
magento/community-edition PackagistFrom 2.3.02.3.2
10 more packages
magento/magento1ce PackagistFrom 11.9.4.2
magento/magento1ce PackagistFrom 11.9.4.2
magento/magento1ee PackagistFrom 11.14.4.2
magento/magento1ee PackagistFrom 11.14.4.2
magento/product-community-edition PackagistFrom 2.12.1.18
magento/product-community-edition PackagistFrom 2.12.1.18
magento/product-community-edition PackagistFrom 2.22.2.9
magento/product-community-edition PackagistFrom 2.22.2.9
magento/product-community-edition PackagistFrom 2.32.3.2
magento/product-community-edition PackagistFrom 2.32.3.2

Products include Magento Magento.

How do I fix CVE-2019-7938?

Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2019-7938 being exploited?

There is no known exploitation of CVE-2019-7938 in the wild and no public exploit code.

All Magento Magento vulnerabilities

Sources

Also known as GHSA-mgfr-44wv-hqv6.

Is CVE-2019-7938 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free