CVE-2019-7947 Magento 2 Community Edition CSRF vulnerability
Attackers can trick users into removing gift card accounts via CSRF, requiring Magento users to upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-7947?
CVE-2019-7947 is a medium-severity vulnerability in Magento Magento, published on 2 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A cross-site request forgery vulnerability exists in the GiftCardAccount removal feature for Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2.
Weakness: CWE-352
Which versions are affected by CVE-2019-7947?
6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.1.0 | 2.1.18 |
magento/community-edition Packagist | From 2.1.0 | 2.1.18 |
magento/community-edition Packagist | From 2.2.0 | 2.2.9 |
magento/community-edition Packagist | From 2.2.0 | 2.2.9 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2 |
Products include Magento Magento.
How do I fix CVE-2019-7947?
Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.
Is CVE-2019-7947 being exploited?
There is no known exploitation of CVE-2019-7947 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-w392-68rg-pgg4.