CVE-2019-7950 Magento 2 Community Edition Access Control Bypass
Unauthenticated attackers can bypass access controls via REST API to join arbitrary companies and read confidential data in Magento.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-7950?
CVE-2019-7950 is a high-severity authentication bypass vulnerability in Magento Magento, published on 2 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An access control bypass vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An unauthenticated user can bypass access controls via REST API calls to assign themselves to an arbitrary company, thereby gaining read access to potentially confidental information.
Weakness: CWE-639
Which versions are affected by CVE-2019-7950?
6 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.1.0 | 2.1.18 |
magento/community-edition Packagist | From 2.1.0 | 2.1.18 |
magento/community-edition Packagist | From 2.2.0 | 2.2.9 |
magento/community-edition Packagist | From 2.2.0 | 2.2.9 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2 |
Products include Magento Magento.
How do I fix CVE-2019-7950?
Upgrade magento/community-edition to a fixed version for your release line: 2.1.18, 2.2.9 or 2.3.2.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2019-7950 being exploited?
There is no known exploitation of CVE-2019-7950 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-2fhr-f6q6-c4p2.