CVE-2019-8107 Magento 2 Community Edition Arbitrary File Deletion
Authenticated users with export privileges can delete arbitrary files on the server via crafted requests in Magento.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-8107?
CVE-2019-8107 is a medium-severity path traversal vulnerability in Magento Magento, published on 5 Nov 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An arbitrary file deletion vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with export data transfer privileges can craft a request to perform arbitrary file deletion.
Which versions are affected by CVE-2019-8107?
4 open source packages ship an affected version, including magento/community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.2.0 | 2.2.10 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p1 |
magento/community-edition Packagist | From 2.3.0 | 2.3.2-p1 |
Products include Magento Magento.
How do I fix CVE-2019-8107?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.10 or 2.3.2-p1.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2019-8107 being exploited?
There is no known exploitation of CVE-2019-8107 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as GHSA-2cg3-w597-rjfv.